Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to configure the time on my system, as per one of the ntp servers provided on net. However, the time doesn't change. I am doing this on Ubuntu 12.04 which is installed in Oracle VirtualBox with Windows 7 as the host system.

saasbook@saasbook:~$ su 
root@saasbook:/home/ubuntu# pgrep ntpd
root@saasbook:/home/ubuntu# cd ..
root@saasbook:/home# cd ..
root@saasbook:/# ls
bin    dev   initrd.img  media  proc  sbin     sys  var
boot   etc   lib         mnt    root  selinux  tmp  vmlinuz
cdrom  home  lost+found  opt    run   srv      usr
root@saasbook:/# vi etc/ntp.conf

In there, I add one server as shown

driftfile /var/lib/ntp/ntp.drift

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable

# The server specified by me

# Use servers from the NTP Pool Project. Approved by Ubuntu Technical Board
# on 2011-02-08 (LP: #104525). See for
# more information.


After that I save the changes and restart the ntp as follows

root@saasbook:/# /etc/init.d/ntp restart
 * Stopping NTP server ntpd                                              [ OK ] 
 * Starting NTP server ntpd                                              [ OK ]

Even after doing all these, the time on my system does not change. Is there something I am mising ?

share|improve this question

migrated from Dec 11 '12 at 17:57

This question came from our site for professional and enthusiast programmers.

It probably won't work because you're on a virtual server and you can't adjust the clock of the Windows host. What happens if you try this as root? ntpdate – Diego Basch Dec 9 '12 at 5:45
It gives me this time 8 Dec 21:46:41 ntpdate[2498]: the NTP socket is in use, exiting. However, the time in my country is different. – CSSS Dec 9 '12 at 5:47
Seems that you're trying to use ntpd and ntpdate at the same time. ntpdate is for manual updates, ntpd is a daemon which does updates automatically. – Sergey Romanovsky Dec 10 '12 at 3:43
One more thing -- why did you decide that your time doesn't change? Could you show "grep ntpd /var/log/daemon"? – Sergey Romanovsky Dec 10 '12 at 3:47
Please add the output of ntpq -p. – Martin Schröder Dec 12 '12 at 20:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.