Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

(Windows 7 x64, Logitech MX1100 mouse)

If I click/hold/ the mouse, like on the title bar of a folder to move it, or to select text, the mouse will randomly "unselect" it and then randomly reselect at another point in the movement.

For example, if I were to start mouse-selecting the above paragraph, starting with "movement." and then moving backwards, it might select as far as "reselect", but then the selection would disappear, only to start selecting again from "will randomly".

I realize this would sound like a clear-cut case for a hardware issue in the mouse button, but I've narrowed out that that's not the case. The problem doesn't happen if I drag-move/drag-select slowly. But I can make the problem very apparent if I click and drag something fast. For example, if I click and hold the title bar of a window, and then start quickly dragging it around in circles across my monitor, the window will get "dropped", and a new window will get picked up in the process.

Additionally, if I right-click anywhere to get a context menu (in Windows, programs, anywhere/everywhere), and then relatively quickly press the left mouse button to select something on the context menu, the context menu will disappear as if I had clicked "through" it.

I haven't had any driver changes, system updates, or significant software changes/updates/installations recently, that might be a precursor to this issue. Again, the oddity seems to be the "speed" of action.

Another note -- it seems that "lag" has a bit to do with it. If I click and drag a window around quickly, it might start to "lag" a tad bit, like it's perhaps moving too fast for Windows to keep up with the refresh/redraw rate, and that's usually synonymous with this odd deselect bug happening.

(Batteries fully charged, no damage or recent changes to mouse, no changes that might affect/block wireless communication)

EDIT:

If I click and hold on something, like a folder in Windows Explorer, it sees it as a double-click. Yet, if I just click and let go once, it doesn't follow through like a double-click (I thought maybe the single-click link-behavior might have been inadvertently activated).

share|improve this question
3  
Have you tried a different mouse? Have you tried plugging the receiver into a different USB port? Have you added any new devices to your computer that connects over USB (or in general)? –  Ben Richards Dec 11 '12 at 23:13
4  
As sidran said, try a different mouse. I had a mouse left button go bad on me and it exhibited almost the same issues you've described. –  Karan Dec 11 '12 at 23:27
1  
I agree with the hardware issue. On a slightly bad button, it will often work fine on slow speed - but when we move the mouse faster the pressure points changes on the button, which may trigger more sensitivity problems. If the mouse is still on warranty, it's highly advised to try another mouse so you can address it as soon as possible. –  mtone Dec 11 '12 at 23:53
    
I certainly would try a different mouse (and a different USB port) before I looked for other causes. Also, if this is a laptop I'd want to be sure that your other hand wasn't resting on the touchpad. –  Daniel R Hicks Dec 12 '12 at 2:29
    
Thanks for the suggestions. Unfortunately, the problem's disappeared before I could further diagnose :/ But if/when it returns, I'll swap mouses. –  Coldblackice Dec 17 '12 at 9:52

4 Answers 4

up vote 9 down vote accepted

This sounds like it could be a hardware issue. I posted some questions so you can help clarify your situation, but the reason this happens could be because (in order from most likely to least likely):

If you're on a laptop, input from both the external mouse and internal touchpad can interfere with each other. If there are mulitple pointing devices connected, it also can cause strange behavior. Windows wasn't designed to accept competing input from two mouse pointing devices at the same time and be able to deal with each separately. So if something is accidentally bumping the touchpad or something else while you're trying to do something with the mouse, it might cause things like you describe to occur.

Your mouse button is starting to go. Because of their constant use, it's likely that they'll be the first to go due to wear. The contacts might be a bit finnicky and have become sensitive to nearly indetectible changes in pressure on the button. Different behavior while using the mouse in different ways might cause misclicks. The behavior might be beyond whatever debouncing the circuitry in the mouse is able to do.

The battery could be losing its charge. If it's a rechargeable battery, it's good to note that they do tend deteriorate over time. It should take a while before it causes an issue, but it can happen somewhat quickly if you tend to overcharge the battery. Even if it reports being fully charged, it still may not be providing enough power to maintain reliable communication with the computer.

Your wireless signal might be getting interference. Perhaps another device could be interfering with the wireless communication between the receiver and the mouse. Even if the device doesn't transmit, they still can emit EM interference and cause other devices to behave erratically. But if you have something else in the vicinity that transmits on the same frequency and by chance is being picked up by the wireless receiver, it might be confusing the two devices, similar to trying to use two different remote controls to control the same TV at once.

Your USB receiver for the mouse might be malfunctioning. If it gets unplugged, stored, transported, and replugged-in quite a bit, it's possible that it experienced wear to the point that it began malfunctioning. Storage in excessive heat or cold can also cause damage to electronic components (same goes with the mouse itself).

The USB port you're using could be faulty. This isn't an unheard of situation. Perhaps the USB root hub isn't working correctly because it's misconfigured. Checking the Device Manager can help you determine if this is a problem or not. Or, there could be a physical problem with the port itself. Since they get a ton of use, especially with devices like this, wear can occur and there might be a broken solder connection, or bent pin, that isn't connecting reliably and interrupting USB communication with the device.

Or, you could be having conflicts with other USB devices on your machine. This doesn't tend to be the issue these days, as operating systems these days are very good at managing USB devices. However, there's always potential for a rare case to happen that causes issues. Again, the Device Manager can report if there are any resource conflicts.

share|improve this answer
    
Thanks for the tips! Unfortunately, the problem "seems" to have disappeared; at least, temporarily. I'll keep an eye out for it repeating, and will continue diagnosing with your tips above. Thanks! –  Coldblackice Dec 17 '12 at 9:54
1  
@Coldblackice Good luck! –  Ben Richards Dec 17 '12 at 19:09
    
PS - Just for reference, it actually was a matter of the button switch physically deteriorating. The mouse has been replaced, and now all is well! Thanks! –  Coldblackice Mar 29 '13 at 20:53

To eliminate the fact that it's not a TOO NEW DRIVER issue:

  • uninstall your updated driver, reboot, then install the driver that came with your mouse.

The driver that is sold with the mouse MUST work and is error checked. Newer versions can be become incompatible with older hardware, as new features are added gradually. I doubt they test it with ALL previous hardware - they test it with some, and they suppose it works with the rest.

To verify it is not a BUTTON HARDWARE issue:

  • swap the mouse buttons in the driver (most software have an option for this, for left handed users).

The left mouse button is supposed to be less used, and if it works properly, it's a very high chance it's a button hardware issue. If it shows the same erratic movement, it's a different problem. In case:

  • Microswitch is defective --> change it
  • Solder joints got defective over time --> resolder it

See this post for instructions: http://www.kaibader.de/logitech-m705-how-to-fix-a-defective-mouse-button/

share|improve this answer

Temporarily disable the touchpad. solved my problem. for some reason hardware/software conflict

share|improve this answer

I had the same problem. Try changing the battery. It fixed my mouse copy problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.