Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using CentOS 6.3 x86_64 on a hardware with a BCM43224 chip for wi-fi. I installed the b43-fwcutter module and then run modprobe b43, with no error messages. However, no new network interface showed up, and the return of iwconfig is:

lo        no wireless extensions.
eth0      no wireless extensions.

lspci -nn | grep 43224 returns:

03:00.0 Network controller [0280]: Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)

and uname -a:

Linux localhost.localdomain 2.6.32-279.14.1.el6.x86_64 #1 SMP Tue Nov 6 23:43:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Any ideas of how to make the wireless device work?

share|improve this question
add comment

2 Answers 2

First what comes to my mind that could be lacking is wireless-tools package. Check if they are installed, I don't know if CentOS puts that in standard installation packages.

You can also try to put wireless adapter online with ifconfig wlan0 up if it didn't work automatically.

There is one post on the other website of an user with a similar problem, could be of help

share|improve this answer
add comment
up vote 1 down vote accepted

After doing some research, I've just used Broadcom's own driver. It's not ideal, it taints the kernel with non-GPL stuff, but it's working (kernel-tainting is just a philosophical problem, it just has to do with licenses and has no effect whatsoever in how the driver works). I'll just have to recompile the module every time I update the kernel... oh well.

So, I got the driver from http://www.broadcom.com/support/802.11/linux_sta.php, untarred it and tried to compile it (running make in the same directory where the file was uncompressed).

After a bunch of errors I've edited the file at src/wl/sys/wl_cfg80211.c (which came with the tar file), replacing every occurrence of KERNEL_VERSION(2, 6, **) with 0 (zero). After compiling the wl.ko module, I ran modprobe lib80211 and then insmod wl ; modprobe wl, and voilà, problem solved.

To make it simpler, the commands below install the 64 bits module:

wget http://www.broadcom.com/docs/linux_sta/hybrid-portsrc_x86_64-v5_100_82_112.tar.gz
mkdir wldir
tar -xvzf hybrid-portsrc_x86_64-v5_100_82_112.tar.gz -C wldir
cd wldir
sed -e 's/KERNEL_VERSION(2, 6, ..)/0/g' src/wl/sys/wl_cfg80211.c -i
make
modprobe lib80211
insmod wl.ko
modprobe wl

For the 32 bits one, just replace hybrid-portsrc_x86_64-v5_100_82_112.tar.gz with hybrid-portsrc_x86_32-v5_100_82_112.tar.gz

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.