Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had this problem for a long time, here is the basics of it... I use a mixed environment of Windows 7/8 computers with Mac OSX Lion/Mountain Lion. Whenever a Windows computer creates a file on a SMB share on the Mac it no longer has group permissions, only the person who created or updated it can access it. My solution has been to go onto the Mac system and reset permissions for the entire directory structure then everyone can see it again.

About the only thing on this that I can find was for OSX pre Snow Leopard that mentioned editing the SMB.CONF file to fix their particular problem (similar to mine, http://www.gladsheim.com/blog/2009/09/19/osx-leopard-and-samba-permissions/). The problem is that now Lion and Mountion Lion no longer have an SMB.CONF file (another web search pointed to the com.apple.smbd.plist (http://kidsreturn.org/?s=smb.conf) but it's an XML file now and I'm not clear on what should be done to THAT to fix the problem.

So, short of me writing an Applescript to run every hour to fix permissions, does anyone know a solution to this very frustrating problem?

Thank you in advance for any advice or solutions you can offer!

share|improve this question

migrated from stackoverflow.com Dec 12 '12 at 12:40

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Although I prefer the Samba "force group", "force create mode", and "force directory mode" combination, that approach is effectively obsolete (or at least too much trouble) starting with OS X Lion. Right now, the best solution is to use groups and ACLs.

In System Preferences -> Users & Groups:

  1. Create a new group for the users who need write access to the file share. Do not try to reuse the "staff" group, a new group is required to force ACLs to be created in step 4.
  2. Add the users to the group.

In System Preferences -> Sharing -> File Sharing:

  1. Select the shared folder.
  2. Add the group to the share permissions (click the + under the "Users" list) and give it read/write access.

Check the ACLs on the shared directory and its contents using 'ls -le'. You should see something like this:

-rw-r-----+ 1 scott    staff  43667456 Feb 17 21:59 filename
 0: group:xxx inherited allow read,write,execute,append,...

The permissions are inherited; all group members now have r/w access.

share|improve this answer
    
I followed these instructions and I can see a similar result for ls -le but I’m missing the word inherited. What should I do to change it? –  Melebius May 17 at 9:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.