Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have AMD radeon 7470M 1gb garphics card, i installed ubuntu in the nomodeset, after my first boot, i jst opened it from boot screen by pressing 'e' and replaced “quiet splash” with "nomodeset", it worked fine i can login but after that i installed AMD catalyst drivers for my graphics card, they are not working and even i opened the rc.local file as the root user 'sudo nano /etc/rc.local' copied and pasted the following lines just before the line exit 0 :

  1. chown -R $USER:$USER /sys/kernel/debug
  2. echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

it doesn't work for me, even time which i boot to OS i need to replace "quite splash" with "nomodeset" by pressing 'e' in the boot screen, then only i can login to Ubuntu.

How can i fix this its very difficult for me every time i should replace that thing.

thank you

share|improve this question

migrated from stackoverflow.com Dec 12 '12 at 13:31

This question came from our site for professional and enthusiast programmers.

    
This should go to askubuntu.com –  EGHDK Dec 12 '12 at 11:48
    
I agree with @EGHDK. But I am still going to give a hint. You can add what you want to /boot/grub/grub.cfg Although it might get deleted if you update grub2. –  Tuim Dec 12 '12 at 12:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.