Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use emacs in ubuntu and I use Monaco 10 as its default font. However, the font rendering seems a bit odd compared to my gnome terminal with the same font size: It's a bit smaller and not as clear as that in the terminal. I've tried to avoid simply this with size 11 but it's too large for me.

How can I make it the same as its look in the terminal ? Any help is appreciated :)

UPDATE: I should tell you the above one is GUI emacs running a shell, and the below is the gnome terminal. On the right are their correspond font settings.

enter image description here

Both 100% capture with font size 10: (left: emacs, middle: terminal, right: gedit)

emacs terminal enter image description here

One more (gvim's):

gvim

I've test it with emacs -q, so there should be no other place affected my font setting.

And I've test this under:

  1. GNU Emacs 24.2.2 (x86_64-unknown-linux-gnu, GTK+ Version 2.24.13) of 2012-12-13 on tales(stable);

  2. GNU Emacs 24.3.50.1 (x86_64-unknown-linux-gnu, GTK+ Version 2.24.13) of 2012-12-12 on tales

They are exactly the same. And here is my ./configure output, I don't know if it can help.

Also I've tried something like changing the .Xdefaults file, but it didn't make any sense.

share|improve this question
    
How are you setting the font in emacs? Could you post an image of it so we can compare and better understand the problem? Also 10 is really quite small, try setting emacs's font to ~14 or so. –  terdon Dec 12 '12 at 16:32
    
@terdon The only font setting in my init.el is (set-frame-font "Monaco-10"). 10 is suitable here. You can open the image in new tab then zoom in to 100% to see how exactly its size is. –  displayname Dec 12 '12 at 16:35
    
As far as I can tell from the image, you are showing two terminals and no emacs. –  terdon Dec 12 '12 at 16:40
    
@terdon I sorry for I should tell you the above on is GUI emacs, and the below is the gnome terminal. On the right are their correspond font settings. –  displayname Dec 12 '12 at 16:42
    
Ah, gotcha, sorry since they were both showing directory listings I was confused. –  terdon Dec 12 '12 at 16:55

2 Answers 2

Based on the images you provide, it looks like emacs is using a dark grey background and light grey fonts while the terminal has a black background and white fonts. That might explain why the one looks brighter than the other. Try setting the same colors in both and see if they still appear significantly different. The difference in size is so small I can't be sure if its not just an illusion born of the different colors.

Another thing to check is the anti-aliasing settings of both.

share|improve this answer
    
I've add some images, the emacs font size is different from any other software me here. Ignoring the colors, they are in different height. –  displayname Dec 12 '12 at 16:57
    
@Ispinfx, so they are indeed. Make sure you don't have any font settings anywhere else (e.g. ~/.emacs), maybe there are multiple definitions and emasc is following one of the others. –  terdon Dec 12 '12 at 17:02
1  
I am sure of it since I've tested it in emacs -q –  displayname Dec 12 '12 at 17:04

It seems that there is a bug in Emacs Xft font driver as described here.

You can workaround it with font setting in .Xresources file for Emacs:

Emacs24.font: Monospace-10:pixelsize=14

For changes to take effect you need to either restart X server or run xrdb -merge .Xresources and restart Emacs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.