Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I solved this problem in Jaunty, but the Sound preferences menu has extensively changed in Karmic. What is the new way to do this?

Original question: I always have my master channel muted, and I switched the volume applet to adjust the headphone channel. This way, sound never comes out of my speakers, but it's always on when I plug headphones in.

However, when I use my Fn keys to adjust volume, they adjust the "master" channel, rather than the "headphone" channel. How do I change this behavior? If it makes a difference, I am using a Dell Inspiron 1200.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

you can use xbindkeys: Run xbindkeys -k in a terminal. Press your keybinding, and add the appropriate line to your ~/.xkeybindkeysrc. for example, With an 'amixer' command to raise/lower your headphone volume.) Don't forget to have xbindkeys start before your windowmanager. You can have a look here for more on xbindkeys. This way, you're not dependent on DE, and you can even transfer you keyboard short cuts to other distros/releases.

(I know it's not exactly what you want, but it might solve your problems?)

share|improve this answer
add comment

For some reason I can't take a screen shot with the drop down, but can you try clicking on the connector drop down and selecting the headphones output? I'm using karmic and a dell and mine says "Analog Headphones". I think that may do it for you.

enter image description here

share|improve this answer
    
Right now my volume is all screwed up, so that I can't adjust it at all. Once I get it fixed (probably not 'til Lucid, by the look of things), I'll test this and see if it works. –  Matthew Dec 31 '09 at 22:13
    
Matthew is anything being logged in error logs when you try to change the volume (and it's failing to change) ? This seems pretty darn screwed up to me; if you have your data directories consolidatated it might be worthwhile to back everything up and reinstall. –  pbr Jan 15 '10 at 1:08
    
@pbr It appears to be a bug in the linux kernel. The kernel isn't correctly reporting the dB level. For some reason, this won't be fixed in karmic, but will be fixed in lucid. See bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/410948 –  Matthew Jan 17 '10 at 1:41
add comment

If you can't find any configuration option, you could take the barebones approach and assign those function keys to a raw command which increases or decreases the volume on the headphone channel. Karmic uses some crazy pulseaudio whatsit, but I think the alsa commands will still work, namely: aumix.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.