Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My problem is I'm try to compare two folders which are almost same but some little difference. But when I compare both of the folders then it shows difference in each file.
When i open the file its not showing any difference except on the top One is PC another is Unix see below screenshots.
enter image description here

So is there any setting to ignore this difference .

Thanks.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

It works for me but only to an extent. I thought the folder compare was showing them as different.. before, but then I clicked on them and it said same. I did a compare again and I see it shows them as = which is what you want. so it's certainly possible to show them as equal, which is the result you want. right? but thing is, it came after I double clicked the file.

notice the byte size is different, that is because one is \r\n and one is \n.

Initially I got a screen showing difference in the sense that, the colors were different, and when I clicked "View..Show Same", the files that had different line endings but were otherwise the same, didn't show. Session..folder compare info also didn't say that ggg.a was the same in both folders.

enter image description here

The main screen showed them as the same once I double clicked one and viewed the two files in a new tab to view the files, then the previous tab I was in, if I recall, updated to show this. that ggg.a was the same (Despite the byte difference). enter image description here

It's unfortunate I had to double click the file to do it, but BC can do it. You might find how to automate it more, or do it more efficiently with BC.

ADDED- dangph's answer looks like it then. Session..session settings..comparison tab. My one was set to "rules-based" but that "compare contents" box has to be checked too. I see it says "requires opening files". I think once that "compare contents" -there- is checked then opening files is automatic. When doing Action..compare contents, it says crc, or binary or rules. I've chosen rules(not binary), but it only works for the pc/unix thing, when the "compare contents" box is also checked in session..session settings screen. Even though one is choosing "compare contents" when doing action..compare contents! And even though one is not choosing binary. That "compare contents" box has to be checked in session..session settings.

share|improve this answer

Works for me. Here are my session settings for the folder compare. They are the defaults so far as I know. Maybe you are doing a CRC or Binary comparison.

Screenshot of Session Settings for Folder Compare

share|improve this answer
    
that looks like it then. Session..session settings..comparison tab. My one was set to "rules-based" but that "compare contents" box has to be checked too. I see it says "requires opening files". I think once that's checked it is automatic. When doing Action..compare contents, it says crc, or binary or rules. I've chosen rules(not binary), but it only works for the pc/unix thing, when the "compare contents" box is also checked in session..session settings screen. Even though one is choosing "compare contents" when doing action..compare contents! –  barlop Dec 14 '12 at 9:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.