Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to develop a Rails app, and I'm using the Windows XP mode (Windows Virtual PC) under Windows 7 to allow testing under Internet Explorer 8.

I have XP Mode setup to use the host's network card, and can freely access the internet, and ping in both directions. I have (temporarily!) turned off Windows firewall on both machines.

I'm running a Rails server on port 3000 of the host, and have specified that it should bind to the host's IP (rather than 0.0.0.0). However, I cannot view the app from IE8 on the XP Mode VM (pointing it to :3000).

Any suggestions what might be wrong?

share|improve this question
    
IF you are trying to develop, why are you using IE8? More then main job is to write model/controllers code rather then views. So you can write your code/test it and after that just upload it to herolu, so you could test your views –  sanny Sin Dec 13 '12 at 16:04
    
Because I've had a bug report that it doesn't work properly in IE8, so I need to point a local IE8 at it to debug. However, I suppose you're right that I could point IE8 at a staging version running live... –  Chowlett Dec 13 '12 at 16:22
    
There is "portable" versions of each IE versions, so your best option would be to download and use it, instead of virtual machine. Here is the first on google tredosoft.com/Multiple_IE?page=6. Also try this my-debugbar.com/wiki/IETester/HomePage, and this finalbuilds.com/iecollection.htm –  sanny Sin Dec 14 '12 at 8:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.