Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an asus Gigabit Router and a gigabit NIC (Realtek PCIe GBE Family Controller) witch is running at 100Mbps rather than 1000Mbps (1.0 Gbps). When I use an old laptop on the same Ethernet cable(cat6) its running succesfully at 1.0 Gbps. Means there's no problem with the setup, router nor the cable. I tried changing the speed & duplex from auto negotiation to 1.0 Gbps but its still running at 100.0 Mbps. I also have the latest driver update for my NIC. I have both side cable wired as T568B and I have RTL8167 driver version 7.65.1025.2012

I think im missing something but what ? What could be the problem ?

share|improve this question
1  
Make sure you are using Cat5e cable or higher –  JustinD Dec 13 '12 at 18:20
    
I would suggest trying another cable. Don't disable auto-negotiation. If you can't even negotiate 1Gbps, it almost certainly won't work if forced. –  David Schwartz Dec 13 '12 at 19:45
    
Is your internet access faster then 100mbit/s? If not, then this shouldn't bother you much. –  David Dec 13 '12 at 20:33
    
internet access on an other computer on the same router is 120mbps and im using cat6 cable. I use the same cable and i got 1gbps speed on my old laptop but on my pc i just get 100mbps –  Sammy Dec 13 '12 at 20:45
    
I have exactly the same problem. I did manage to get it attached at 1Gbps briefly a couple of times by disconnecting and reconnecting the cable, but it always reverts to 100Mbps. I've resigned myself to getting a new card. –  vlad259 Jan 30 '13 at 15:28
add comment

1 Answer

My guess is your cord is too long or there is too much noise on the line. Your laptop's NIC may not care too much, but the other does. You could try using a very short(3-6') CAT6 cable attached directly from the PC to the gigabit device to see if this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.