Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While visiting a website, I notice this behavior on my PC. I have set up a simple example to illustrate.

Let's say I have a webpage which has two links. The first is a link to a document on a website. The other is a link to a document on a file share. When I click the first link, the document on the website is opened in a new Internet Explorer window. When I click the second link, the document on the file share is opened in a new tab. Both have a target attribute set to blank.

Here is a basic sample of the HTML.

<html>
    <body>
        <a href="http://myWebsite/documents/someDocument.pdf" target="_blank">Link 1</a><br>
        <a href="file://myServer/folder/someOtherDocument.pdf" target="_blank">Link 2</a>
    </body>
</html>

I want the document on Link 1 to open in a new tab as it does for Link 2. I have done some homework and I know this involves the Tabbed Browsing Settings in IE on my machine. As you can see below, I have it set to Always open pop-ups in a new tab.

enter image description here

Thus, why is the document on the website not automatically opening in a new tab? I know I may right-click and select Open in new tab or click the middle mouse button/scroll wheel, but I would like to know why the tabbed browsing setting is not working. For the record, I am using Internet Explorer 9.

share|improve this question
    
Which PDF reader's IE plugin are you using? Maybe another one will work as expected? –  Karan Dec 13 '12 at 21:44
    
I am using Adobe Reader X. Based on your suggestion I tried FoxIt Reader. It had the same results. It opens the website document in a new window and the file share document in a new tab. –  Dark Lord of the Code Dec 14 '12 at 21:19
    
In IE, go to Internet Options / Security and disable Protected Mode, then close and relaunch the browser. Does that change anything? –  Karan Dec 14 '12 at 22:46
    
Protected Mode was the culprit. If you would, please post your comment as an answer, and I'll give you credit. I moved the website in the link to the trusted zone and disabled protected mode on the trusted zone. It has been working great ever since. –  Dark Lord of the Code Dec 17 '12 at 20:10

1 Answer 1

up vote 1 down vote accepted

Try disabling IE's Protected Mode under Internet Options / Security, since it may be causing this. Adobe Reader X onwards also has its own Protected Mode which you can read about here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.