Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am currently using an Ubuntu 12.10 installation, all-updated.

Now, I wanted to download some heavy source code using Mercurial ( Firefox's ) considering on another partition on the same drive where my OS resides considering that my partition has a few hundred MBs left.

However, far from this; I am not even able to accomplish the seemingly simple task of navigating to the other drive which is supposedly in '/media/Username' folder as I can't climb 'above' my Home Folder in the Terminal using the cd.. command. Please help.

share|improve this question

migrated from Dec 14 '12 at 0:14

This question came from our site for professional and enthusiast programmers.

There needs to be a space in between: "cd .." –  ernestopheles Dec 13 '12 at 20:45
Ubuntu also has a file manager, it looks somewhat different from the windows explorer, but does the same tasks. On a console screen, you might want to use mc. –  ott-- Dec 13 '12 at 20:51
Thanks @ernestopheles.. that was helpful.. –  purezen Dec 18 '12 at 16:22

3 Answers 3

up vote 3 down vote accepted

Did you try the following?

$ cd /media/Username
share|improve this answer
Hey.. thanks there..!! It really did solve the purpose. –  purezen Dec 17 '12 at 9:51

( i assume you will replace username with your correct user, and i assume your user belong in a group of the same name ).

First of all verify you really have a /media/username mounted: ls -la /media/username/

you should see at least :


if it is ok then :

cd ~
sudo mkdir /media/username/mywork
sudo chown username:username /media/username/mywork/
ln -s /media/username/mywork/ bigdata

everything you will put into bigdata will then be on new bigger disk since it is a link.

pushd bigdata

... do your mercurail download here ... ... once finished ...

share|improve this answer
Thanks.. It worked out for me..!! –  purezen Dec 17 '12 at 10:42

Do you see any error message after typing cd command? Maybe you haven't the permission to see that path.

Try to write cd command with sudo which will ask your password and then give you the permission to do that.

sudo chown yourUserName /media/username
cd /media/username

or try to list that directory

sudo ls /media/username
share|improve this answer
Except then the shell that sudo spawned will exit, leaving you with nothing more than practice typing your password... –  twalberg Dec 13 '12 at 21:11
how ls gives permissions ? –  zb' Dec 13 '12 at 21:27
sorry, ls doesn't give permissions. I changed. –  Muatik Dec 13 '12 at 21:32
Thanks..! but already solved the issue.. –  purezen Dec 17 '12 at 10:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.