Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a MacBookPro connected to an AiportExpress' Wi-FI network.

Every once in a while, the Wi-Fi will choke up and either drop some packets, or lag horribly for several seconds.

I'm losing hair over this because every time I chat on Skype, the call hangs randomly due to this problem.

Any idea what's wrong?

Some more details:

  • two networks are set up: 2.4Ghz and 5Ghz, and the issue happens on both
  • the network uses WPA2 Personal for security
  • the Airport is in the same room with my computer
  • the Airport is fairly new, bought this summer, model number off the back: A1392
  • tried connecting to a neighbours wifi to see if it's a problem with my computer, or interference. It's not, it doesn't happen on their network.
  • tried resetting it several times
  • tried changing channels manually

Ping results are below, so you can see what I'm talking about. EDIT: is the Airport's IP

64 bytes from icmp_seq=1795 ttl=255 time=0.813 ms
64 bytes from icmp_seq=1796 ttl=255 time=3.335 ms
64 bytes from icmp_seq=1797 ttl=255 time=3.403 ms
64 bytes from icmp_seq=1798 ttl=255 time=3.414 ms
64 bytes from icmp_seq=1799 ttl=255 time=3.227 ms
64 bytes from icmp_seq=1800 ttl=255 time=3.274 ms
64 bytes from icmp_seq=1801 ttl=255 time=3.253 ms
64 bytes from icmp_seq=1802 ttl=255 time=3.292 ms
>>>>  choke starts  <<<
64 bytes from icmp_seq=1803 ttl=255 time=53.977 ms
64 bytes from icmp_seq=1804 ttl=255 time=35.049 ms
64 bytes from icmp_seq=1805 ttl=255 time=19.820 ms
>>>>  choke ends  <<<
64 bytes from icmp_seq=1806 ttl=255 time=0.716 ms
64 bytes from icmp_seq=1807 ttl=255 time=0.705 ms
64 bytes from icmp_seq=1808 ttl=255 time=0.919 ms
64 bytes from icmp_seq=1809 ttl=255 time=0.659 ms
64 bytes from icmp_seq=1810 ttl=255 time=0.877 ms
64 bytes from icmp_seq=1811 ttl=255 time=0.679 ms
64 bytes from icmp_seq=1812 ttl=255 time=0.854 ms
64 bytes from icmp_seq=1813 ttl=255 time=0.644 ms
64 bytes from icmp_seq=1814 ttl=255 time=3.779 ms

... time passes ..

64 bytes from icmp_seq=1599 ttl=255 time=0.674 ms
64 bytes from icmp_seq=1600 ttl=255 time=0.930 ms
64 bytes from icmp_seq=1601 ttl=255 time=0.665 ms
64 bytes from icmp_seq=1602 ttl=255 time=1.085 ms
Request timeout for icmp_seq 1603
Request timeout for icmp_seq 1604
64 bytes from icmp_seq=1605 ttl=255 time=104.969 ms
64 bytes from icmp_seq=1606 ttl=255 time=11.521 ms
64 bytes from icmp_seq=1607 ttl=255 time=0.926 ms
64 bytes from icmp_seq=1608 ttl=255 time=0.993 ms
64 bytes from icmp_seq=1609 ttl=255 time=0.745 ms

And the Signal-Noise ratio:

enter image description here enter image description here

share|improve this question
Try turn off the 5GHz. Additionally, are SSID on both 2.5GHz and 5GHz same? – John Siu Dec 23 '12 at 6:38
What tool are you using to get the signal strength? – ranman Dec 28 '12 at 6:34

Wifi stability is highly influenced by any elecromagnetic emission you have near you: fridge, tv, power plugs on walls etc. To troubleshoot a problem, try to move your WiFi airport express to different place, preferrable anothe building / house. If problem persist, it's hardware problem. If not - it's positioning problem and you need to place airport inside your appartments in different places and select the best one.

share|improve this answer

I am having a similar problem and I think I have found out what causes the choke (music skipping) in my case. It happens when I open or close my fridge door and also when the fridge compressor starts-up or powers-down. The interference is coming through the power socket and not through electromagnetic interference. Maybe the same in your case?

share|improve this answer

You must log in to answer this question.

protected by JakeGould 12 hours ago

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .