Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Linux laptop died yesterday and now I can't watch TV. Let me explain.

I use a Roku Player to stream Netflix shows to my television; and a year or two ago, the Internet Service provided in my apartment complex added a Splash Page to get through the router and onto the net. After not too many days, I remembered that internet devices identify themselves with a MAC address (Thus the splash page must create a lease between the MAC and granted IP). So I delved into the manpage of ifconfig and discovered that I could persuade my laptop to pretend to be the Roku Player, connect, click through the Splash Page, disconnect and change it back. This would allow the Roku to connect for about 24 hours, when I would have to do it again.

But the laptop died yesterday during my smoke break. So during lunch, I ran to OfficeMax and got a new one (it was the last day before my "stay-cation", the prospect of no tv, no computer was to terrible to bear :,). But I don't know where to begin looking for where to change the MAC address (assuming it's possible). I know I can try dual-boot, or a keychain OS, or possibly other things to resurrect my old method. But, is it possible to get Windows do it?

share|improve this question

4 Answers 4

up vote 8 down vote accepted

You can change the address in the device manager of Windows

  • Start Device manager
  • locate the network device
  • open the properties and look for the entry Network Address and enter your MAC adress you want.

enter image description here (source: mydigitallife.info)

share|improve this answer
1  
Excellent. Thank you. I'll give it a try as soon as Cygwin finishes downloading. :) –  luser droog Dec 14 '12 at 5:11
    
Sadly, my version of the above window does not list 'Network Address'. I had to try the regedit route and further misadventures. I'm accepting this to thank you with some points, but for the wayward answer-seeker, scroll down! –  luser droog Dec 20 '12 at 10:30
    
@luser droog in this case your NIC driver doesn't support the manual override of MAC address. –  magicandre1981 Dec 20 '12 at 12:07
    
Yes, at least not fully. It can be changed to random macs so long as they all begin 0x02. –  luser droog Dec 20 '12 at 12:13
1  
s/random/arbitrary/ –  luser droog Feb 19 '13 at 7:39

UGH! They don't make it easy!

I followed the directions from @magicandre1981's answer, and it didn't work (Network Address not present in property list). So I followed the directions in the link, and it didn't work (no change in MAC address).

So, I tried using this freeware program, and it didn't work (no change in MAC address). But at the bottom of the window, there was an option to use 02 as the first byte when selecting a random MAC, and link to "why".

So, it appears that Windows 8 requires you to use 02 as the first byte if you want control of the number. It sets a flag in the card enabling "Locally Administered". With this I was able to make the MAC address change.


Sadly, this still doesn't solve the problem. Since the Roku's address doesn't start with 02, using one that does will not trick the router! Repairing the Linux laptop appears to be my best option.

share|improve this answer
    
I should add that it appears not to be "Windows" fault, this is implemented in the installed network device (but it does appear common for Windows installations). –  luser droog Dec 20 '12 at 10:27

I'm surprised it hasn't been mentioned yet, but I have always used SMAC to change my MAC address on Windows.

It is compatible with Windows 2000, XP, 2003, VISTA, 2008, Windows 7. It's a bit dated but you may be able to get it to work and play nice with Windows 8. They have a SMAC 2.7 beta that might have a better chance of succeeding.

Once you do get it working, it works like a charm and I've always had great luck with it.

Side Note:
Why don't you just install your linux distro and dual boot or wipe the drive and install?

share|improve this answer
    
Because I believe the problem to be in the hardware (the network adapter), not the software. –  luser droog May 30 '13 at 19:50

dankst's solution is fine - you just need to do some work for yourself.

  1. delete the drivers for your network card and install the xp drivers for the same card.
  2. now change the mac address from device manager.
share|improve this answer
    
How are these steps accomplished? –  Kevin Panko May 9 at 2:45

protected by Community May 9 at 4:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.