Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Kubuntu 9.04, a GeForce 9800M GS (laptop) video card with nVidia's drivers, version 180. If I press Ctrl-Alt-F1 (or F2-F6) I should go to a fullscreen text console (instead of the X server running on terminal 7). This works if I use the default drivers, but not if I use the nVidia ones. Instead, it goes to a fully black screen (backlight off), with sound no longer audible (songbird is so nice to actually pause the music)

(How) can I solve this? I need the nVidia drivers, or stuff will be slow and ugly.

Here is my xorg.conf. You should know that I've never touched it, it's all automatically managed:

Section "Monitor"
    Identifier      "Configured Monitor"
EndSection

Section "Screen"
    Identifier      "Default Screen"
    Monitor         "Configured Monitor"
    Device          "Configured Video Device"
    DefaultDepth    24
EndSection

Section "Module"
    Load    "glx"
EndSection

Section "Device"
    Identifier      "Configured Video Device"
    Driver  "nvidia"
    Option  "NoLogo"        "True"
EndSection
share|improve this question
    
could you post your xorg.conf? It could help in finding a solution. –  John T Oct 6 '09 at 21:17
    
Ok i've posted it. It's rather short though. –  Bart van Heukelom Oct 6 '09 at 21:23
    
When you press Ctrl-Alt-Fn nothing happens? –  Captain Segfault Oct 6 '09 at 21:28
    
Woops, forgot to explain that. Edited my question –  Bart van Heukelom Oct 6 '09 at 21:54
    
Please post your Xorg.0.log –  fpmurphy1 Jan 24 '11 at 1:22
show 1 more comment

2 Answers

up vote 0 down vote accepted

I upgraded to Kubuntu 9.10. It has new nVidia drivers (version 185 I think) which fixed this problem

share|improve this answer
add comment

If that's your complete xorg.conf, it's highly incomplete. It's missing descriptions of your mouse and keyboard, for two. It also doesn't set a resolution anywhere, e.g.

Option:      "metamodes" "CRT: nvidia-auto-select +1280+0, DFP: nvidia-auto-select +0 +0"

You may want to regenerate xorg.conf, for instance by running "sudo nvidia-settings".

share|improve this answer
1  
in jaunty (ubuntu 9.04) xorg.conf is extremely minimal; they're phasing it to a detect-everything mode. this is why mouse & kbd are missing. karmic (9.10) won't even install an xorg.conf, tho supposedly you can create your own if needed. –  quack quixote Oct 7 '09 at 3:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.