Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have downloaded libavg from https://www.libavg.de When I do ./configure it gives me error

checking for libpython2.7... configure: error: could not find files required to build python plugin

I have installed libpython2.7_1.0 and python-devel. I am using OpenSUSE 12.2 (64 bit).Help.

share|improve this question

1 Answer 1

At least, I can reproduce this behaviour ...

checking for python... /usr/bin/python
checking for python version... 2.7
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking for headers required to compile python extensions... found
checking for libpython2.7... not found
configure: error: could not find files required to build python plugin

It appears to me that there is something broken in how the packages are organized (maybe some Python 2 vs. Python 3 issue). Maybe it is a good idea to post the issue here: http://lists.opensuse.org/opensuse-factory/

share|improve this answer
    
But I am not using any factory repo? Where should i report the issue? –  Abhijit Navale Dec 15 '12 at 4:35
    
You are right, but IF this happens due to "design" problems within the packages, it may actually be good to post it to kind of the main developer mailing list. Most people in the project read the factory list. –  ernestopheles Dec 15 '12 at 12:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.