Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some laptops where I noticed that the wifi is not working. The correct driver is installed. In device manager there isn't any yellow exclamation mark. The two network ( the local and the wifi ) adapters are in ok in device manager.

The problem is, if I turn the wifi on, I can't see any wifi connections where I could connect to. If I install Intel pro Wireless manager, it says there is no wifi adapter in the laptop (or something like that).

If I run the command

netsh wlan show interface

it says that the device is not ready. I have two specific laptops which I can't reinstall, because tomorrow morning someone will come for them, and on these two laptops there is two OS installed. The rest of the laptops I could reinstall, but it would be easier if I could solve the problem.

Has anyone have any idea how could I solve this?

Update:
I forgot to tell, that there is two OS installed on one laptop. Not on everyone, only these particular two, and on the corporate OS the wifi is not working, but on the private OS it is working, so the problem is not with the device.

Update 2:
I also forgot to tell, that if I run ipconfig /all the wireless network device is not listed.

share|improve this question
    
Were there any errors during OS installation? Or go the vendor's website, download the relevant drivers and install them (preferably a clean install if the option is there). HTH –  pratnala Dec 14 '12 at 17:25
    
You mean to say that wifi started working after you re-installed the OS? –  VenkatH Dec 14 '12 at 17:26
    
What laptop model are we talking about –  BroScience Dec 14 '12 at 17:29
    
@PratyushNalam: No, there were no errors during installing the OS. The newest drivers are installed, but I also tried to install some older ones. –  kampi Dec 14 '12 at 17:37
    
@VenkatH:No. I wanted to say, that I don't want to reinstall the OS, but probably a reinstall would solve the problem. –  kampi Dec 14 '12 at 17:38
show 12 more comments

1 Answer

The E6520 and E6320 have physical switches on them that control the wireless radio (on the right side of the laptop next to the keyboard). Have you made sure those are turn on? Since the device seems to be installed properly, perhaps the switch is just off.

share|improve this answer
    
No, that's not the case. They are turned on. –  kampi Dec 14 '12 at 17:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.