Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded from Win 7 -> Win 8. AppFabric was not one of the programs that came up as being incompatible when I ran the upgrade wizard, so I did not uninstall it. Now whenever I goto "Add or remove features" I get the following error:

---------------------------
Windows Server AppFabric Setup Wizard
---------------------------
Windows Server AppFabric is not supported on current operating system Windows 8 Pro(version 6.2.9200.0). Please refer to installation guide for the list of supported operating systems.
---------------------------
OK   
---------------------------

Unfortunately the only way to uninstall AppFabric is via the "Add or remove features" - does anyone know a commandline command to kick the uninstall so I can at least access "Add or remove features"?

Edit:

C:\Windows\System32\AppFabric\Setup.exe /remove

Throws the same error as above.

share|improve this question
1  
You can try downloading and running the installer again, maybe it has a repair or remove option. –  Louis Dec 14 '12 at 17:55
    
@Louis - thanks for the reply, still get the same error when running the install for both 1.0 and 1.1: Windows Server AppFabric is not supported on current operating system Windows 8 Pro(version 6.2.9200.0). Please refer to installation guide for the list of supported operating systems. –  downatone Dec 17 '12 at 14:54
    
Don't you have a Uninstal.exe in the Application folder? /Program Files/AppFabric/Uninstal.exe? There should be something like that. –  mnmnc Dec 17 '12 at 15:34
    
@mnmnc - install path is C:\Windows\System32\AppFabric, there is only a Setup.exe (which throws the same error above when I try to run it), guessing they wrapped the uninstall in the Setup.exe –  downatone Dec 17 '12 at 15:59
    
If you wish to keep AppFabric, you could try to set the compatibility setting of its executable to Vista or earlier. –  harrymc Dec 18 '12 at 7:36

5 Answers 5

You can use MyUninstaller utility to uninstall AppFabric from your PC. It can run standard uninstaller or if that fails, remove install reference from register.

If you'll perform uninstall via deleting registry entry, you should manually delete folder with AppFabric, most likely in c:\program files\ or c:\program files (x86)\. After deleting that, you may run registry cleaner in ccleaner, to clean .dll and other file references to AppFabric in registry.

But If you want only overcome your problem with that ugly error message, deleting uninstall registry entry or uninstalling AppFabric with myuninst or ccleaner should suffice.

share|improve this answer
    
MyUninstaller did not list AppFabric as an app that it could uninstall (btw - Add/Remove Programs also does not list it, it can only be done via Add or remove features) –  downatone Dec 18 '12 at 14:23

Find the executeable for the uninstaller and run it in compatibility mode for Windows 7 or any other earlier system, which may be supported by AppFabric.

You should look in your start menu folder (%APPDATA%\Microsoft\Windows\Start Menu\Programs\AppFabric\somethinghere) and also in the installation directory located in either C:\Program Files or C:\Program Files (x86) depending on your system (and the application) architecture.

To enable compatibility mode, you should right click the executeable and click properties. Go to the compatibility tab and put a checkmark in the box next to "Run this program in compatibility mode for:", choose Windows 7 in the box and hit OK. Now you can just try running the uninstaller.

I've had the same problem with several other programs, such as Logger Pro and Maple 15, and I found this simple workaround to work out nicely.

In case it did not work, you can also try uninstallers such as Revo Uninstaller. It will launch the uninstaller executeable, where you should simply just close it again, since it doesn't work. From here, Revo will now search for any related files that have not been removed. Delete all the files related to AppFabric. Next dialog will do the same for registry entries. Watch out for which items you delete. Removing the ones not in bold is usually fine. Once you've done that, the program should be gone.

share|improve this answer
    
Setting compatibility to Windows 7 didn't do the trick –  downatone Dec 18 '12 at 14:15
1  
Does Revo detect the program? Have you looked for the installation directory and registry keys? –  Time Sheep Dec 18 '12 at 18:17

When I uninstall programs I use Iobit's Advanced Uninstaller application. It has a Powerful Scan mode which can be used after the normal removal process which seeks out leftover registry entries.

http://www.iobit.com/advanceduninstaller.html

share|improve this answer
    
Same issue as the MyUninstaller link above - doesn't work –  downatone Jan 2 '13 at 19:38
    
@downatone The only other thing I can suggest is ADW Cleaner bleepingcomputer.com/download/adwcleaner –  Simon Jan 2 '13 at 20:50
    
I'm using few years Advanced Uninstaller PRO: advanceduninstaller.com Really very good free uninstaller. –  miky Mar 13 at 9:13

An application can always be deleted manually by brute-force.

Basically the steps are as follows:

  1. Find all the directories used by the application (normally their names will contain "AppFabric")
  2. Delete (or rename first) all these directories
  3. Use regedit to search for all references to these directories and delete carefully the keys (meaning prefer to delete from the left-hand panel rather than the right-hand.) If you are not sure, google for information or add a comment to this answer (if I can help).

Take precautions such as creating a system restore point and other backups before editing the registry.

share|improve this answer

If AppFabric uses MSI for installation, you could try to manipulate the MSI package (must be somewhere on your system) to accept Windows 8, then you should be able to uninstall AppFabric. On how to manipulate MSI packages, consult the search engine of your least distrust. There are programs for doing that as well as manual ways.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.