Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm tired of using Tab key when I pressed Enter and Tab Key in SSMS editor because when I have something like this:

CREATE PROCEDURE SP_Example
BEGIN
        SET NOCOUNT ON

        SET DATEFORMAT MDY

If the caret is after the SET NOCOUNT ON sentence and then I press Enter, the caret position goes to the beginning of the next line instead of doing two Tabs.

How can I fix it?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Make sure you have Block indenting turned on for T-SQL files:

  • In the Tools menu select Options.
  • In the options window expand the "Text Editor" node and the "Transact-SQL" node to select the "Tabs" node.
  • Ensure Indenting is set to "Block"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.