Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Google Apps for my organization's user accounts and email. It is very convenient to have our users use Google's OpenIDs to log into various websites, including StackExchange, without them having to create and maintain YET ANOTHER password.

OwnCloud seems like a neat project for filesharing, and I have an instance installed. Supposedly OwnCloud supports OpenID authentication instead of custom usernames and passwords but I cannot find any documentation on how to configure that. I have enabled "OpenID user backend" and "External User Support" apps in my owncloud instance, but I can't figure out how to use them - especially for Google Apps OpenID (and without enabling Google+ for the OpenID)

It's a little confusing to know whether the OpenID support is for using the OwnCloud instance as the OpenID authority or, as I need it, accepting of OpenIDs for logging in.

Further, even if I knew how to log in to the web application, I also want to use the OwnCloud thick-client (windows) and continue to use the OpenIDs for logging in with that program. I don't see that as an option.

I would set a bounty on this except I don't have the points. Anybody want to open a bounty for it?

share|improve this question
    
When you login normally, do you see a new option in Personal / Settings that allows you to enter the openid provider? –  Paul Dec 15 '12 at 2:20
    
Yes, but I can't figure out what to put in there. Doesn't seem to matter what I put in, but I also don't know what it should be - Google Apps OpenId is weird and no guess changes the behavior. –  uosɐſ Dec 15 '12 at 2:59

3 Answers 3

Don't expect the login screen to change.

After configuring my OwnCloud local user with a identity at my OpenID provider, the browser is redirected to my auth server right after submitting my OpenID identifier to the OwnCloud login page, so this part of the process works fine.

Unfortunately, the login process does not succeeded because finally I'm redirected to the OwnCloud login page again (it does not show any error, by the way)

Update (Apr 24, 2013):

I've started to look into the code and I've found that OwnCloud uses class.openid.v3.php wich does not seem to support OpenID v2.0 (see http://stackoverflow.com/questions/6724729/has-any-one-got-class-openid-php-working-with-google-openid)

(Please note that this is very preliminary information. Maybe the file class.openid.v3.php supplied with OwnCloud have been upgraded to suport the latest release of OpenID. In fact, http://openid.net/developers/libraries/ says that "Simple OpenID PHP Class" is 2.0 compatible)

share|improve this answer
    
You have to log into you OwnCloud with the user account AND THEN ALSO log in to your OpenID? I get that it then fails for you, but are you saying you would have to log in twice? –  uosɐſ Apr 20 '13 at 23:13
    
No, you don't have to log in twice. What I'm saying is: 1. I try to log in with my OpenID identity at my OwnCloud instance 2. OwnCloud redirects to the user authentication portal at my University 3. I log in using my auth portal with my University credentials 4. My auth portal redirects back to OwnCloud 5. For some yet unknown reason, OwnCloud does not recognize the authentication process and shows again its login screen. –  rpet Apr 22 '13 at 15:47
    
How do you do step 1?? How is OwnCloud supposed to tell the difference between a local-Username and OpenID? What format OpenID do you type in to the login screen? Isn't that what you already typed into your Personal settings in OwnCloud?? –  uosɐſ Apr 23 '13 at 12:10
    
My guess is that OwnCloud looks for authorized OpenId identifiers in the user database. Anyway, the fact is that I only have had to declare http://yo.rediris.es/soy/userid@my.domain in my user profile, log off, and log in again with that identifier. Depending on the browser, you may have to supply also a fake password. –  rpet Apr 24 '13 at 18:01

According to this fourm post you put your OpenID url in the username field.

If you are logging in with Google that is either your Google+ profile url or https://www.google.com/accounts/o8/id (for all accounts).

I'm sorry I couldn't test it but I don't run an instance of owncloud.

share|improve this answer
    
Well, I can put in https://www.google.com/accounts/o8/id and it "saves" it, but nothing happens. There are no further options and the login screen doesn't change. –  uosɐſ Jan 30 '13 at 17:20
    
I'm sorry, but as I said I don't have an instance of owncloud. Best of luck to finding the solution. –  Kevin Cox Jan 30 '13 at 20:37

One alternative I explored was using the "external auth" options, especially SMTP auth against Gmail. That also did not work properly. The the other alternative was using OAuth 2.0, but that involved pointing my whole Google apps domain at an external server.

It seems there are few mature plugins for ownCloud available at present. Using alternative authentication also prohibits you from sharing data among users and generally lacks features.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.