Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am no Windows guy, but I am trying to get a seamless integration of Windows program through Virtual Box Windows guest onto my Ubuntu machine. I more or less followed this tutorial: https://nowhere.dk/articles/running-windows-applications-natively-with-seamlessrdp

Basically I start up Windows in Virtual Box and then I try to launch an application (on Ubuntu host) like this:

rdesktop -A -s "c:\Program Files\ThinLinc\WTSTools\seamlessrdpshell.exe notepad.exe" -u user -p password

That just gives me full Windows desktop that I do not want. However, when I run (on the Windows guest)

"c:\Program Files\ThinLinc\WTSTools\seamlessrdpshell.exe"  "notepad"

The command above works and I get just the window I want. Now, so I thought I would put this command into startup folder of the Windows machine and everything would be fine. But it says "Unable to set up the virtual channel". (by googling, I nailed it to this file: https://sourceforge.net/p/rdesktop/code/1686/tree/seamlessrdp/trunk/ServerExe/vchannel.c - the warning is triggered (by main.c in the same directory) when function vchannel_open() returns something that C interprets as yes for if condition).

I have no idea why it works when I launch this command manually via a bat file and not when I put it to startup programs. Any ideas?

share|improve this question
did you give it admin privileges? –  Lorenzo Von Matterhorn Dec 17 '12 at 14:55
Hm, that might be it. How do I do that in windows? I thought that when I have admin priviledges, it would inherit them. –  sup Dec 17 '12 at 18:25
right click on it, then properties –  Lorenzo Von Matterhorn Dec 17 '12 at 18:31
Are you sure? i do not see any option for that. This is on windows xp (I should have said that in the question, I see I did not mention it). After some googling, I do not see a easy solution to this (most links talk of Vista and higher). –  sup Dec 17 '12 at 19:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.