Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Background

I've been running a KVM switch with my monitor at 1920 x 1080 over VGA for over a year. Did a Windows Update on 12/11/12 which did the following:

  • Update for Windows 7 for x64-based Systems (KB2779562)
  • Security Update for Windows 7 for x64-based Systems (KB2779030)
  • Cumulative Security Update for Internet Explorer 8 for Windows 7 for x64-based Systems (KB2761465)
  • Windows Malicious Software Removal Tool x64 - December 2012 (KB890830)
  • Security Update for Windows 7 for x64-based Systems (KB2753842)
  • Security Update for Windows 7 for x64-based Systems (KB2758857)
  • Security Update for Windows 7 for x64-based Systems (KB2770660)

After a restart, my extended monitor was dark. I attempted to reset the extended display configuration, and noticed my monitor was being detected as a Generic Non-PnP Monitor:

I uninstalled, downloaded new, and re-installed display drivers. Nothing. I attempted to unplug my monitor from the power for 15 minutes. Nothing. I followed some of the suggestions on this thread; specifically DanM's which suggested to create a new *.inf file and replace that in Device Manager. Device Manager said the "best driver software for your device is already installed".

The only thing that works is when the monitor is directly attached to the laptop. This obviously is not what I want. My thought is to somehow remove the Generic Non-PnP Monitor from registry. How would I accomplish this and would this help? Any other suggestions?

Relevant Hardware

  • ASUS VE276 Monitor
  • TRENDnet 2-Port USB KVM Switch (TK-207K)
  • HP Laptop w/ ATI Radeon HD 4200

Screens

share|improve this question

2 Answers 2

up vote 0 down vote accepted

It did not occur to me to "reset" the switch itself. I removed both cables and reattached them. After "resetting" the switch, it works as expected. The monitor is detected properly.

share|improve this answer
    
i'm having the same problem How did you "reset" the switch? –  PhantomAid May 24 at 20:14
    
@PhantomAid unplug both connections to the switch to make sure that it doesn't have power. Then reboot both computers. –  Kermit May 24 at 22:09

In the Resolution window, click Advanced Settings, open the Monitor tab, and uncheck Hide modes that this monitor cannot display.

Then try adjusting the resolution again.

Please correct me if I'm wrong, but generally, when using a KVM, you're essentially using the "monitor chip" inside the KVM that simply passes information along to the real monitor, and so your system may not actually see the ASUS VE276.

share|improve this answer
    
The checkbox is greyed out to show hidden modes. The other Windows box that is attached detects a Generic PnP Monitor. –  Kermit Dec 15 '12 at 0:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.