Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a external Harddrive today, A Samsung. But I'm not able to do anything with it A few notes on that.

  • I can't put anything on the harddrive. It keeps on 'preparing copying files'
  • I can delete anything on the harddrive system files, except the folder ".Trashes". It gives error 'Unexpected error: -50'
  • I've tried to empty my own trashcan, no changes.
  • I've set the file permission on the .Trashes to read/write everyone, doesn;t change a thing
  • Trying to format the whole drive with DiskUtility, but quits at start, because the drive cannot be deactivated

I've tried a few terminal commands

  • sudo -s -r rf /Volumes/Untitled\ 1/.Trashes - Directory not empty
  • -r rf /Volumes/Untitled\ 1/.Trashes - no permissions

Also

  • cd /Volumes ls -al cd name_of_partition ls -al
  • -rm -rf .Trashes

Again: Permission error.

Also:

  • I can't change drive permissions via Disk Utility, via the button 'recover drive permissions', because it is 'blank'

I really can't figure out how to delete .Trashes, format the drive or get the damn thing working.

Any suggestions?

p.s. If this is the wrong Stack Exchange site: Please redirect me!

share|improve this question

1 Answer 1

You need to erase the drive. Go into Disk Utility, click on the drive in the left area and from the tab options on the right First Aid, Erase, Partition, etc. choose Erase. Click the Erase button to start the erase process. This will write a fresh partition map and HFS+ filesystem onto the drive, overwriting the partition the manufacturer left on the drive.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.