Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running OS X 10.6.8 on a Mac Mini. I tried to install 3 applications today and all 3 installations failed. I am wondering if the failures have something in common.

First I installed GraphViz. The installation succeeded, but when I try to open any .dot file, I get a dialog that says GraphViz has quit unexpectedly.

Next I installed Doxygen. It installed, but when I try to launch it I get a dialog that tells me Doxywizard quit unexpectedly.

After some googling I thought perhaps my system lacked QT, and that was the problem. I downloaded the Qt 4.8.4 packages and installed them. But when I try to launch qtdemo.app, or any of the other apps that came with the qt installation, I get a dialog that says I can't open the app because it's not supported on this type of Mac.

I have crash logs from GraphViz and Doxygen. They're long and I think it unnecessary to post them unless they would help someone determine my problem.

Thanks

Excerpt from System Log, added later:

12/13/12 5:26:21 PM [0x0-0x4f04f].com.apple.DiskImageMounter[1322]  2012-12-13 17:26:21.927 DiskImages UI Agent[1333:903] *** -[NSMachPort handlePortMessage:]: dropping incoming DO message because the connection or ports are invalid
12/13/12 5:30:31 PM [0x0-0x1a01a].org.mozilla.firefox[824]  [ConvConfHandler] isPreferred contentType: application/x-apple-diskimage
12/13/12 5:35:32 PM DiskImages UI Agent[1384]   *** -[NSMachPort handlePortMessage:]: dropping incoming DO message because the connection or ports are invalid
12/13/12 5:35:32 PM [0x0-0x5a05a].com.apple.DiskImageMounter[1376]  2012-12-13 17:35:32.988 DiskImages UI Agent[1384:903] *** -[NSMachPort handlePortMessage:]: dropping incoming DO message because the connection or ports are invalid
12/13/12 6:07:33 PM DisplayLinkUserAgent[772]       (00116500.405)-[DLDistributedNotificationCenter stream:handleEvent:] reconnected.
12/13/12 6:07:33 PM [0x0-0x6c06c].backupd-helper[1446]  Not starting Time Machine backup after wake - less than 60 minutes since last backup completed.
12/13/12 6:08:43 PM Installer[1403] PackageKit: *** Missing bundle identifier: /Library/Receipts/BrotherPPD.pkg
12/13/12 6:08:48 PM Installer[1403] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Intel.pkg
12/13/12 6:08:48 PM Installer[1403] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Patch-2-Intel.pkg
12/13/12 6:08:48 PM Installer[1403] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.5-Intel.pkg
12/13/12 6:08:48 PM Installer[1403] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice.pkg
12/13/12 6:08:48 PM Installer[1403] PackageKit: *** Missing bundle identifier: /Library/Receipts/PIXMA iP6000D 290.pkg
12/13/12 6:14:39 PM com.apple.launchd.peruser.501[359]  ([0x0-0x70070].com.att.graphviz[2047]) Job appears to have crashed: Bus error
12/13/12 6:14:41 PM ReportCrash[2056]   Saved crash report for Graphviz[2047] version 2.28 (2.28.0) to /Users/duzzell/Library/Logs/DiagnosticReports/Graphviz_2012-12-13-181441_Amun.crash
12/13/12 6:15:19 PM com.apple.launchd.peruser.501[359]  ([0x0-0x74074].org.doxygen[2070]) Job appears to have crashed: Bus error
12/13/12 6:15:19 PM ReportCrash[2056]   Saved crash report for Doxywizard[2070] version 1.8.2 (???) to /Users/duzzell/Library/Logs/DiagnosticReports/Doxywizard_2012-12-13-181519_Amun.crash
share|improve this question

migrated from stackoverflow.com Dec 15 '12 at 9:35

This question came from our site for professional and enthusiast programmers.

    
its hard to say without some kind of log... in this case i would think the system log would be better to look at for some initial thoughts. It wont give a full dump just the errors if any preceding the crash. Also how did you install? If they were from installer packages i would think qt would be bundled with each app... –  prodigitalson Dec 14 '12 at 2:54
    
I installed GraphViz and Doxygen by downloading dmg's and dragging the apps to my app folder. Qt was a set of packages that came with an install script. System log coming... –  David U Dec 14 '12 at 2:57
    
My setup was indeed incomplete. I used MacPorts to download and install the GraphViz sources. It took 2 hours with all the dependencies that were needed. GraphViz works now. Thanks. –  David U Dec 14 '12 at 17:20
    
I was going to suggest macports or homebrew but didnt know if you wanted to go the pkgmanager route. Glad you got it working! –  prodigitalson Dec 14 '12 at 17:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.