Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i did this command :

curl -I 'http://criminaljustice.state.ny.us/cgi/internet/nsor/fortecgi?serviceName=WebNSOR&templateName=detail.htm&requestingHandler=WebNSORDetailHandler&ID=368343543'

but stuck

but if i did this :

curl -I 'http://criminaljustice.state.ny.us/cgi/internet/nsor/fortecgi'

HTTP/1.1 200 OK
Content-length: 207
Content-type: text/html
Server: Sun-ONE-Web-Server/6.1
Date: Sat, 15 Dec 2012 08:49:14 GMT
Via: 1.1 proxy-internet-revproxy
Proxy-agent: Oracle-iPlanet-Proxy-Server/4.0

then i try shorten it :

curl -I 'http://criminaljustice.state.ny.us/cgi/internet/nsor/fortecgi?serviceName=WebNSOR&templateName=detail.htm'

stuck too

i dont know why

seems like if the url contain "=" it stop responding

so tried this url removing the "=" (serviceName=WebNSOR to serviceNameWebNSOR) :

curl -I 'http://criminaljustice.state.ny.us/cgi/internet/nsor/fortecgi?serviceNameWebNSOR'

HTTP/1.1 200 OK
Content-length: 207
Content-type: text/html
Server: Sun-ONE-Web-Server/6.1
Date: Sat, 15 Dec 2012 08:50:38 GMT
Via: 1.1 proxy-internet-revproxy
Proxy-agent: Oracle-iPlanet-Proxy-Server/4.0

why i cant use = ? please assist me

share|improve this question
    
please check out those formatting buttons on the input field, they'll help you make a better question. Also, use interpunction, Capital letters, the 'apostrofe' can be your friend too... –  Nanne Dec 15 '12 at 8:57
add comment

migrated from stackoverflow.com Dec 15 '12 at 16:26

This question came from our site for professional and enthusiast programmers.

1 Answer

This is not the = that does the problem, but the ?.

You need to inhibit the ? such as :

curl -I 'http://criminaljustice.state.ny.us/cgi/internet/nsor/fortecgi\?serviceName=WebNSOR&templateName=detail.htm'
share|improve this answer
    
hmm it works but why must use \? it never happen before, do i have to configure something to make it work using '?' only? –  user1512778 Dec 15 '12 at 9:04
    
also if i use curl_setopt to post that url, it stuck on my php script –  user1512778 Dec 15 '12 at 9:06
    
This is not a problem with curl, but with the request. You are requiring HEAD using the -I option, but you pass GET arguments after a ?. Do you see the problem? - About your PHP script, your question do not mention it so I can't help. –  Ninsuo Dec 15 '12 at 9:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.