Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to mount a supplementary ext4 data disk drive with specified rwx permission for a certain user. The mount point is inside the home of such a user and it's owned by the user. I added the new data disk in /etc/fstab in the standard way:

/dev/hda  /home/user/new_disk  ext4  defaults,errors=remount-ro  0 1

Anyway when the new partition is mounted, the ownership of the mount point change from user.group to root.root and so the user has no write permissions there. I can change manually the ownership of the mount point so the user can write there, but the problem reappear at each rebooting. I've even tried to add the disk in the fstab in the following way:

/dev/hda  /home/user/new_disk  ext4  umask=0077,uid=1000,gid=1000,errors=remount-ro  0 1

But in this case the system gives me an error because the volume has ext4 format. I want to either:

  • mount the ext4 drive already with specified user permission, or
  • change the ownership of the mount point at each startup after the disk has been mounted.
share|improve this question
    
Who will be mounting the disk? Should the user himself be able to mount it? –  holgero Dec 15 '12 at 21:42
    
I think that if I use the words "user,users" in the mounting options of fstab, the user would be able to mount the disk. –  green69 Dec 16 '12 at 11:41
    
There's a similar question on Ask Ubuntu. –  Cristian Ciupitu Aug 1 at 12:32

2 Answers 2

I've just encountered the same problem. What I've done is mounted the filesystem first, then changed all the permissions and owner:group on the mount point, subdirectories, and files. Then when I umount the filesystem and remount it these changes appear to be persistent.

15:24@boromir:/media$ cat /etc/fstab
UUID=95446ed0-b6a6-42cd-8c37-ea81a0836e98 /media/cavalry1  auto   defaults,nofail       0 0

15:26@boromir:/media$ sudo umount cavalry1/
15:27@boromir:/media$ l
total 28
drwxrwxrwx 2 boincuser boincuser 4096 2012-12-17 15:00 cavalry1/

15:27@boromir:/media$ sudo mount -a
15:28@boromir:/media$ l
total 28
drwxr-xr-x 3 boincuser boincuser 4096 2012-12-17 11:05 cavalry1/

Here you can see the permissions and owner aren't reset upon remounting the filesystem.

share|improve this answer

Only FAT, vFAT, exFAT support the uid, gid, umask options. You can check this by reading the list of the possible options in the mount man page, section "Mount options for fat".

However, you can change ownership of the existing directory system by using chown on the filesystem's mount point, like:

# mount /dev/sda* /mnt/your/mountpoint/
# chown user:group 741 /mnt/your/mountpoint/
share|improve this answer
1  
That changes the permissions on the file system permanently. Any user/group differences will be wiped out, and any SUID/SGID bits will be reset. –  vonbrand Jan 30 at 16:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.