Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My girlfriend has this external hard drive by Western Digital called a My Book.

When the external drive is connected, it does not show it as an accessible disk drive on the computer. However, it shows up fine in Device Manager:

enter image description here

I can also see it in Disk Management, but the volume is not mapped to a drive letter, nor can I change the drive letter:

enter image description here

It only gives me access to Delete Volume:

enter image description here

I would rather not lose the data on the drive if possible. What can I do from here to get to the data?

Things I've tried/know:

  • Uninstall drivers and re-install them
  • Device does the same thing when attach to either her Win7 laptop or my Win8 laptop
  • I don't think there's an issue with the HDD itself. No clicking noises, etc. I ran Western Digital Data LifeGuard Diangostics (DLGDIAG) and the SMART Status was a "PASS", all of the SMART Disk Information looked fine. I haven't had the time to run the diag tests yet but I do not believe it's a mechanical issue.

The hard drive is inside of an enclosure, I have not attempted to pry the drive out yet.

How can I get Windows to properly detect this drive?

share|improve this question
add comment

3 Answers 3

up vote 4 down vote accepted

Looking at the last screenshot, you see the drive having 2 partitions: 1) UEFI, 2) Primary. Plus some empty space. No file system is shown for that primary partition -- while for the other disk they are clearly displayed. This leaves two possibilities:

  1. the partition is unformatted
  2. the file system used is unknown to Windows

As you speak of data you don't want to lose, I rather assume the latter. Could it be the drive was formatted using a different OS, say e.g. Linux or a Mac?

My recommendation would be: Download yourself a Linux LiveCD, burn it, and boot from it (or use another Linux system if you already have one available), and then connect the drive to that computer. Linux knows a lot more file systems than Windows supports, and its auto-detection works pretty well. Chances are good it will recognize and mount the partition in question.

If that worked out, open a command line and issue the mount command. This should list up all mounted partitions and, amongst other information, also the filesystem used. This way you can find out what it really is.

Also, if it worked out, you can copy all data to another drive, and re-format the partition using a file system supported by Windows -- if that drive should be used there.

EDIT: You also might want to take a look at one of the "related" questions: My Western Digital 500GB Passport disk says “not formatted” when I plug it in Windows. Two of the answers might prove helpful: one mentions TestDisk which I can recommend as well, and the other a LiveCD with a lot of recovering and testing tools (Hiren's Boot CD).

share|improve this answer
    
TestDisk was able to find the lost partition and re-write it, making the disk accessible :D –  Bryan Denny Dec 15 '12 at 22:40
add comment

When I got my WD mybook last year, I had a problem with it not being recognized or only working after unplugging it from the power or USB. Then if I turned the computer off the drive would not show up and I had to do the power/USB thing again. All of which may or may not have worked.

I had solved the problem but then I had to redo my Win7 64 OS. I started having the same problem again but could not remember I had fixed it.

I finally went to the website of my motherboard maker (gigabyte GA-X58A-UD3R (rev. 1.0)) I found the NEC USB 3.0 Driver update and that seems to have worked.

So maybe a USB driver update that is compatible with your motherboard will do it.

share|improve this answer
add comment

In my experience, you do need a recovery tool to recover the inner data at first and then delete this volume to create a new one.
Note:
1. Stop using this drive immediately to avoid overwriting the original data, which can make your data gone permanently.
2. Save your recovered files on a different storage device in case of recovery failure.
3. Do not forget to format your disk to see whether it will work again.
4. Back up you data in the future in case of similar problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.