Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 laptops running Windows 8 and I am using my Microsoft Account between them.

Trouble is, one laptop has a UK keyboard and the other a US keyboard.

So far it seems that the keyboard layout is now attached to my profile and not the machine, which is a problem. I sit down at the UK keyboard and the layout is set to US. I keep typing " instead of @ and vice-versa. So I change it over to UK layout and all is well. Later I open up the US keyboard and its got a UK layout and I'm typing @ instead of " again.

So- Does anyone know of a way to force a keyboard layout to be machine-specific when using Microsoft accounts?

share|improve this question
    
Have you tried telling Windows not to sync this particular setting? –  Ramhound Dec 16 '12 at 1:54
    
This is particularly maddening when the layout switched from QWERTY to dvorak mid-sentence... –  Eric Apr 24 '13 at 20:26

1 Answer 1

up vote 4 down vote accepted

This drove me crazy too. I think I've figured it out.

  1. Go to the charms area (slam into the right-top/bottom corner)
  2. Click on the settings cog
  3. Click on "Change PC settings"
  4. Click on "Sync your settings"
  5. Switch "Language preferences" to "Off"

Pain reduced.

share|improve this answer
1  
Thanks Justin. That was driving me nuts. –  Umar Farooq Khawaja Jun 29 '13 at 17:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.