Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

About my setup:

  • Windows 8 64-bit.
  • X79-UD3 Motherboard.
  • Latest Windows 8 USB 3.0 Drivers from motherboard manufacturer website.
  • Latest BIOS revision. (F12p)

All right so device manager detects my USB 3.0 ports, so all is well there.

However when I plug in my external USB 3.0 hard drive, windows doesn't even make a beep; the hard drive is not picked up by device manager at all.

The SAME thing happens with Ubuntu 12.10 BUT adding PCI=nomsi (as a workaround) to the Grub command line of the Ubuntu boot option makes Ubuntu 12.10 detect my external hard drive.

I also have a few other doubts, if you guys would be kind enough to answer them that include:

  • Should XHCI hand-off in the UEFI bios be enabled or disabled for Windows 8?
  • The difference between XHCI hand-off and EHCI hand-off and what are it's effects on USB 3.0 functionality?
  • And last but not least how can I get Windows 8 to recognize my external hard drive when Ubuntu 12.10 (after the Grub workaround) works fine?
share|improve this question
1  
Tentative answer: Try setting xHCI mode as Auto. If you have both xHCI and EHCI Hand-off then set both of them. If you have "HS Port Switchable" try enabling them. –  harrymc Dec 18 '12 at 20:33
    
There's no auto, just "enable, disabled". Latest BIOS revision btw. I don't have HS Port Switchable either. –  Tek Dec 18 '12 at 20:36
    
What happens if you enable both xHCI and EHCI Hand-off ? –  harrymc Dec 18 '12 at 20:41
    
Absolutely nothing. Not even detected in device manager, like I've said. –  Tek Dec 18 '12 at 21:56
    
As the BIOS offers so few options, it might not be advanced enough for usb-3. Maybe you should look first for a firmware/bios update for your model, or ask the Support of your computer maker whether the motherboard supports usb-3. Apropos : which model is your computer? I also remark that detecting the disk is not enough if it functions only at usb-2 speeds. –  harrymc Dec 19 '12 at 8:32
show 2 more comments

2 Answers

up vote 1 down vote accepted

I believe that both xHCI and EHCI Hand-offs should be set to Enabled. More information may be found in the thread USB 3.0 on Gigabyte UEFI Motherboards - XHCI Mode Explained.

If USB-3 does not work, even though your board expressly supports Windows 8, this may be because your BIOS or drivers are not fully up to date.

The first step is to update the BIOS which is found at this link (if this is not your exact board model then search for it).

Second, download and install the latest Gigabyte drivers for your motherboard, available from the same link.

Exercise very great caution, as an unsuccessful BIOS update can brick your computer. Ensure first that you have a boot installation CD of your current BIOS (and of course - backups).

(On second thought, a boot CD will not help if the BIOS is dead, you will need a repair-shop to get it installed again.)

share|improve this answer
    
Does not the fact it works under Ubuntu rule out the BIOS as the cause of issues? –  deed02392 Dec 19 '12 at 19:33
    
@deed02392: My theory is that the Windows driver requires more capabilities from the BIOS than does Ubuntu, so it needs a more advanced BIOS. –  harrymc Dec 19 '12 at 19:49
    
There was a BIOS update a few days ago and that seemed to have resolved my issue. I was however not sure about XHCI and EHCI so thanks. –  Tek Sep 13 '13 at 20:36
add comment
  • Should XHCI hand-off in the UEFI bios be enabled or disabled for Windows 8? Enabled

  • The difference between XHCI hand-off and EHCI hand-off and what are it's effects on USB 3.0 functionality? only xHCI affects USB 3.0 ports. Set to Enabled for most modern OSs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.