Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Please read this entire message before replying.

First I know how to fix the issue on a temporary basis. I am looking for a permanent fix. I work with foreign language files a lot.

Unfortunately sometimes all the unicode characters in windows explorer, notepad, and other places (as rendered by windows, probably GDI) do not display correctly. That is they display as rectangular blocks, where as they had just been displaying correctly. There are countless methods to temporarily correct the issue.

But again, I want a way to permanently resolve the issue.

What I have tried:

  • The silly "Hide fonts based on language settings". This setting only applies to what fonts you see in the fonts folder and font dropdowns. It doesn't disable foreign fonts (doesn't work, or if it does, it is temporary).
  • Deleting the font cache file and rebooting (works.. usually, temporary solution).
  • Changing my locale and then back (sometimes works, temporary solution).
  • Rebooting my PC and getting lucky (50-50 chance, temporary solution).
  • Changing my keyboard input/adding foreign keyboard (temporary solution that only seems to work once).
  • Reinstalling windows (temporary solution, sometimes lasts a few months though, I have done this 7 times across 3 computers)

What I have not tried:

  • Buying Windows Ultimate and installing the interface packs. This is not a solution. I can't read Japanese/Chinese and I do not want my interface in those languages.

What I will not do:

  • Switch to a different brand operating system (unix, linux, mac os x)
  • Switch to an older version of windows (Windows Vista, XP, 2000, etc).

So can anyone recommend a permanent fix for the problem?

share|improve this question
    
This problem has driven me batty for years. I have contacted Microsoft several times on the problem and they just dodge answering, or they re-iterate one of the above temporary solutions. –  Chase Dec 17 '12 at 9:39
1  
The description is very vague: sometimes some characters are displayed as rectangles (they aren’t really square, are they?) in Windows 7 (as implied by the tagging). I have sometimes seen some fonts get broken, which is probably a Windows level issue rather the font files. So you seem to asking more or less how to remove errors and bugs from Windows and prevent any future errors –  Jukka K. Korpela Dec 17 '12 at 11:16
    
No, not square. Sorry for the misunderstanding there. Basically the display of unicode in fonts constantly breaks, and there is no long term way to fix it. Usually it reverts within days of being 'fixed'. While I would prefer an official way of doing it. A dirty hack is perfectly acceptable. Even a way to temporarily fix it without restarting would go a long way making this error less annoying (could just set that method to run every hour or two, which would 'fix' it). –  Chase Dec 17 '12 at 14:27
    
EDIT: While I would prefer an passive way to fix it. A active dirty hack is perfectly acceptable. Such as a way to temporarily fix it without restarting, which could just be set to run every hour or two, which would 'fix' it. –  Chase Dec 17 '12 at 14:32
    
@Chase (1) How many different types of font/ language you use regularly? (2) How much memory in the computer? (3) What video card you use and amount of memory on the card? –  John Siu Dec 19 '12 at 0:07

4 Answers 4

up vote 3 down vote accepted

I am not sure why it works, but putting a file on your desktop with a name in a Eastern Language (such as Japanese), seems to keep the problem from popping up.

I have no idea how or why this works or even if it is a permanent fix. But the problem has not reappeared since I did so. Please let me know if this works for you.

For example, I just use a blank file on my desktop with the name きぼう.

share|improve this answer
    
For some unknown reason (bug?), Asian characters may display correctly if explorer.exe is the first program to display them, which is why this works and may even be a permanent solution. –  harrymc Oct 29 '13 at 8:08
    
How did you test this? I am trying to find out if this is a feasible solution or not, or if it is just happenstance. –  Chase Oct 29 '13 at 10:03
1  
This is a bug in Chrome which breaks Unicode handling for all of Windows and all programs if Chrome is the first program to access Windows’ Unicode system. Rebooting and making sure that some other program displays Unicode before chrome will fix it. Putting a file on the desktop with a Unicode character in the filename also fixes it because Windows Explorer automatically access the Unicode routines first, before Chrome has a chance to break it. (I don’t know where harrymc got the idea that it is the other way around.) –  Synetech Dec 31 '13 at 4:10
    
Are you sure this is specific to Chrome? I happen to use chrome, but I wonder if anyone who doesn't gets the error. –  Chase Dec 31 '13 at 5:29
    
It’s not a coincidence that you use Chrome; I knew you do because what you described is a 100% match for a well known symptom of this bug. Did you check the Chrome bug-report or the other question? They describe both your problem and your work-around exactly. –  Synetech Dec 31 '13 at 5:32

I've recently experienced the same issue. Yes all the other solutions are only temporary solutions for me as well. The following is a bit of a hack in that you have to change each application separately. For Notepad (and Notepad++ if you use it or other text editors) you should be able to change the font to a unicode font such as Arial Unicode MS, or if you prefer fixed width fonts then try GulimChe (any of the fonts that end in "Che" are fixed width fonts). This works for me for Notepad and other applications where I can specifically choose the font. I have tested this for Korean (Hangul) characters, but assume it works for other Asian characters as well. I know how to change the default font in windows xp (for windows explorer) but haven't figured it out for Win7 yet. Try the following http://windows.microsoft.com/en-au/windows7/change-windows-fonts. Hope this helps...

share|improve this answer
    
I found that placing an icon on your desktop with foreign text seems to 'fix' it for now. This may just be another temporary or fake fix, but it has worked for awhile. I have no idea why it would/does work. –  Chase Jul 6 '13 at 5:35

This is a long shot but did you by any chance run windows update clean up utility via disk clean up which seems to alleviate the issue

Microsoft KB article (KB2852386) http://support.microsoft.com/kb/2852386

share|improve this answer
    
Yes, temporary. –  Chase Nov 5 '13 at 8:59

The only way I have ever fixed that issue is to install the language pack for that language. You don't have to use that language just have it installed. In windows update. look in the Optional updates and the language packs are listed there.

If you already did this I'm sorry for the useless post. I did not see in the question post if you have done this.

share|improve this answer
    
This requires Ultimate, which I don't have. It is an expensive option that most people do not have access too. In my humble opinion, you shouldn't have to pay an extra $100 to fix a bug that shouldn't exist in the first place. –  Chase Nov 5 '13 at 8:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.