Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to create a VM, using VMWare Player, with an ISO image of Ubuntu Server 12.04 (LTS). The machine I'm doing the installation on has an Intel(R) Core(TM) i5 CPU, and runs 64-bit Windows 7

I managed to create the VM (gave username, password, configured network etc), but I can't install Ubuntu Server. First I get this alert : Binary translation is incompatible with long mode on this platform. Disabling long mode. Without long mode support, the virtual machine will not be able to run 64-bit code. For more details see http://vmware.com/info?id=152.

When I click OK, I get another alert : This virtual machine is configured for 64-bit guest operating systems. However, 64-bit operation is not possible. This host supports Intel VT-x, but Intel VT-x is disabled. Intel VT-x might be disabled if it has been disabled in the BIOS/firmware settings or the host has not been power-cycled since changing this setting. (1) Verify that the BIOS/firmware settings enable Intel VT-x and disable 'trusted execution.' (2) Power-cycle the host if either of these BIOS/firmware settings have been changed. (3) Power-cycle the host if you have not done so since installing VMware Player. (4) Update the host's BIOS/firmware to the latest version. For more detailed information, see http://vmware.com/info?id=152.

Then, when I click OK, my VM exists, and I get back to the VMWare Player home screen.

I don't know much about hardware and virtualisation, so there might be some necessary info I'm not giving. Please don't hesitate to let me know what is missing in my post, for finding solutions.

Thanks :)

share|improve this question
    
There are precisely the steps you need to follow right in the alert, numbered and everything. –  David Schwartz Dec 17 '12 at 13:45
1  
A lot of information indeed, overwhelming for newbies. 1) Know what Bios is 2) know that the BIOS is configurable 3) know how to get to it 4) the Bios doesn't mention "Intel vt-x" but "hardware virtualisation : know they refer to the same things Thanks to William Hilsum and NauT, I got the info I needed quickly, and learned frustration-free, instead of spending hours looking up all these questions on my own. –  Myna Dec 17 '12 at 19:10
add comment

1 Answer

up vote 1 down vote accepted

Go in to your bios/efi and enable VT-X (or virtualisation bit/whatever it is called in your BIOS/EFI).

Then... everything should work fine :)

share|improve this answer
    
Thanks a lot for your answer :) is that something I should do on my PC or on the VM ? –  Myna Dec 17 '12 at 11:19
    
@WannaBeAGeek on PC, reboot PC, press F8, or whatever it asking to enter the bios/efi find there something like advance cpu settings and enable VT-X. after boot your windows, start VM player and try to install again –  NauT Dec 17 '12 at 11:23
    
OK on my way to try this out ! Thanks a lot –  Myna Dec 17 '12 at 11:27
    
Worked ! the key to press to access the bios settings depends on the PC used (sony, dell, hp etc) - for sony, it's F2. –  Myna Dec 17 '12 at 13:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.