Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I compile qemu for arm platform, I configure as follows:

./configure --cross-prefix=arm-linux-gnueabi- --target-list=arm-softmmu --enable-kvm --enable-sdl --static

But get errors below:

ERROR: User requested feature sdl ERROR: configure was not able to find it

I don't know what's wrong I use Ubuntu 12.04 with libsdl1.2dev on it I download the source code of qemu from its official site

share|improve this question

migrated from Dec 17 '12 at 12:13

This question came from our site for professional and enthusiast programmers.

Any "fedora" version of this question? –  jayunit100 Nov 26 '13 at 18:03

3 Answers 3

up vote 0 down vote accepted

Yes, this is one of 3 stages I had to pass in my journey to compile qemu for raspberry pi emulation on Ubuntu. SDL gets solved running on console:

apt-get install libsdl-dev-image1.2-dev

And then the next issue you will undoubtedly have:

git submodule update --init pixman
share|improve this answer
thank you very much! –  Himiko Apr 16 '13 at 2:00

I installed the following packages from (I run CentOS 6).

$ rpm -i SDL-1.2.15-1.i386.rpm


$ rpm -i SDL-devel-1.2.15-1.i386.rpm

which did the trick.

share|improve this answer


    apt-get install libsdl-dev-image1.2-dev

doesn't work, then try:

    apt-get install libsdl1.2-dev
share|improve this answer

protected by Breakthrough Jun 20 '13 at 21:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.