Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

UPDATE Dec 27 2012 OK, today after a week or so of mostly trouble free operation and several successful attempts to watch mounted DVD file shared via my other machine and no other problems playing VIDEO_TS folders in VLC, I finally experienced 2 new GUI-related crashes. In both cases when afp was inoperative and other Mac physically disconnected.

My conclusion is that AFP is not involved as a main factor as it's been inoperative many times now when this problem have occurred. I did realize that I got a high number of "Segmentation Fault: 11" in my log for an app I couldn't find first: ByteControllerHelper, which is part of the iTunes controller application ByteController.

I've had this app installed for years under 10.5 and never had any issues with it so didn't first think of it as being involved, but as I now ran an alpha or beta updated for OS X Lion and it did actually hang for a while now and then, it could perhaps be involved. The app do listen for key combinations possibly in an unorthodox fashion and could possibly block interface control for some reason, perhaps by disturbing main OS processes. The situation is now I uninstalled it and will get back to business and use my Macbook daily and reevaluate again.

I'll post any new developments in due time. probably some weeks on given the nature of the problem.

ORIGINAL POST The issue I have is that irregularly I get hung processes that seem to spread in the system and app after app hangs. Typically this feels file system oriented, as if I try and read a disc on the other machine from an app, that app may hang. Sometimes this disc is not reachable from the Finder nor the Terminal, leading to the conclusion this is file system related. At other times, some apps can still reach this disc and operate on the content.

Most often though, while most apps keep functioning fully, app after app hangs, soon seemingly including processes governing the user interface. Sometimes the whole machine is unresponsive, yet one or two apps keep running, like for instance media in iTunes or VLC keeps playing, though the interface is totally unresponsive. Most often the internet will work, but logging in via ssh from another machine doesn't work as there is no response.

I'm on OS X 10.7.4 clean installed on a blank HD. I typically mount drives on other machine connected via afp over Firewire. The hardware is Macbook Pro 2.2ghz merom (Dual core 2), 6gb / 250GB with Nvidia GeForce 8600 GT 128mb. Currently I run in 32bit kernel mode, because of kernel drivers. Running in 64bit kernel mode doesn't seem to make a difference though I don't do that very often.

I've seen this behavior during the lifespan of OS X, often related to externally mounted discs going offline and crashing the File systen as it keeps indefinitely trying to reach a file and never ever giving the user the opportunity to abort. The last 10+ years though this have been very rare, even when I yanked the cord to the external disc.

This issue will arise also when I don't have any external discs mounted. Therefore it's quite hard to provoke this issue to become active which makes it so hard to troubleshoot.

The first 2 months everything was great, so this is new behavior. Most often the problem will occur and then reoccur within hours. The it can work for a week or more without any issues.

I need ideas for how to troubleshoot this and possibly isolate the problem. I fond very little in the logs....[CUT] expanded below.

UPDATE This is the ByteControllerHelper crashes from the log. It's possible the Helper is a separate version than from the one I was actually running, though I'm not sure if it was launched (and relaunched as it crashed) from the Applications folder or from the other non working version sitting in my download folder. The reason being I don't know how the ByteControllerHelper app got started as it did run also when the main application wasn't started since boot. The first time I ran both versions from the download folder. Only one of them worked properly. Anyway here's the log extract (repeating every few minutes):

2012-12-27 21:29:13,911 ReportCrash: Failed to write crash history to file://localhost/Users/[userName]/Library/Application%20Support/CrashReporter/launchproxyls_00000000-0000-1000-8000-001B63A2ECD9.plist.
2012-12-27 21:29:24,028 ReportCrash: Failed to create CSSymbolicatorRef for launchproxyls[1569]
2012-12-27 21:29:24,138 ReportCrash: Failed to create dSYM-less CSSymbolicatorRef for launchproxyls[1569]
2012-12-27 21:29:24,252 com.apple.launchd.peruser.501: (org.bytetastic.ByteControllerHelper[1569]) Job appears to have crashed: Segmentation fault: 11
2012-12-27 21:29:24,253 com.apple.launchd.peruser.501: (org.bytetastic.ByteControllerHelper) Throttling respawn: Will start in 10 seconds
2012-12-27 21:29:24,254 ReportCrash: Saved crash report for launchproxyls[1569] version ??? (???) to /Users/[userName]/Library/Logs/DiagnosticReports/launchproxyls_2012-12-27-212924_macbook.crash

END UPDATE

What do you think? You've encountered this type of issue before?

share|improve this question

migrated from stackoverflow.com Dec 17 '12 at 16:05

This question came from our site for professional and enthusiast programmers.

    
This is actually intentional behavior. AFS tries to imitate the behavior and semantics of a local disk. And when a process accesses a local disk, it hangs for as long as necessary for the disk to reply. And if another process is waiting for that process to respond, it too waits as long as necessary for the first process to access the disk. –  David Schwartz Dec 17 '12 at 16:52
    
But as I hinted this is not the whole story to my problem. This also happen when afp is both turned off and and no external volumes are connected. Also, why would processes not connected to the file system also hang for no apparent reason? What I'm looking for here is ways to investigate this problem further. It's not normal OS X behavior. It's abnormal. –  MiB Dec 17 '12 at 17:08
    
Also, I question this "intentional behavior". It takes down the whole machine. The old Mac OS as a contrast did not do this. –  MiB Dec 17 '12 at 17:10
    
The problem can happen at any time. An unimportant process can be hung and you wouldn't even notice until other processes get stuck behind it. Again, the goal of AFS is to make remote drives behave just like local drives. What do you think would happen to a system if a local drive stopped responding to requests? (I can tell you from experience, it takes down the whole machine.) –  David Schwartz Dec 17 '12 at 17:12
    
OK, but this doesn't make sense for this issue as it doesn't seem to be either connected to afp, external drives nor the local drive being unavailable. If I turn off afp, it still occurs. When one process hangs Finder can still access the same disk. If it was only the file system then why would media keep playing to the end (1 hour or more)? You focus on afp, but I'm stating that turning it off doesn't prevent the problem. There are no issues with the drive. No bad sectors, no permission errors. –  MiB Dec 17 '12 at 17:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.