Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a MacBook Pro with Mac OS X version 10.7.5. Safari's minimize button (the one with a '-' in it in left top corner) is disabled (turned gray) and now either I have to keep Safari on the desktop all the time or close the page and reopen it. I have updated Safari and still the problem has not been solved. How can I fix this?

share|improve this question
    
Are you using third party software that's dealing with window management? Is only Safari affected? Since when does this issue occur? Is there anything interesting shown in Console.app? Does it occur for other user accounts (create some if you don't have any)? –  Daniel Beck Dec 17 '12 at 18:08
    
It has happened since a month ago. I use basic Safari. The only problem I have on machine right now is that after installing Adope flash player, I keep getting some error messages in pages which include videos, as I am not proficient in dealing with computer issues, I push dismiss all and the page opens with no problem. Do you think this is the culprit? –  Solmaz Dec 17 '12 at 19:09
    
I have this problem with Safari only. I have not done anything to my window management. BTW, I've just started using multiple desktops by connecting a monitor to my laptop, and I think this issue with safari started sometime after this. –  Solmaz Dec 17 '12 at 19:16
    
@Solmaz Have you any plug-ins activated? See under Preferences > Extensions. –  NSAddict Dec 17 '12 at 22:37
    
@NSAddict In my Preferences there is not Extensions. However, theres "others". As I mentioned above I kept getting error messages when I watch videos which use Adope Flash player. My problem seems to be solved now, this is what I did. In 'system Preferences" I clicked on 'Flash Player", in the "storage" I clicked on "delete all ..." and then chose the first option, "delete all site data and setting", and then clicked ok. This seems to solve my problem. Can someone explain what was going on? Thank you NSAddict, for putting me in the right path. –  Solmaz Dec 18 '12 at 5:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.