Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At work I am running Windows Server 2008 R2 64-bit and all the clients are Windows 7 32-bit.

I would like all ISO files to open automatically with VLC player when double clicked. At the moment if I login as the administrator and change the default behaviour it works fine, but as soon as a new user logs in, it has to be reset once again (some PCs can have over a 100 users)

How can I fix this?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Try creating and configuring a new File Type Item using Group Policy:

  1. Open the Group Policy Management Console. Right-click the Group Policy object (GPO) that should contain the new preference item, and then click Edit.

  2. In the console tree under Computer Configuration, expand the Preferences folder, and then expand the Control Panel Settings folder.

  3. Right-click the Folder Options node, point to New, and select File Type.

  4. In the New File Type Properties dialog box, select an Action (such as Create) for Group Policy to perform. (For more information, see "Actions" in the linked article.)

  5. Enter file type settings (such as File extension and Associated class) for Group Policy to configure or remove. (For more information, see "File type settings" in the linked article.)

  6. Click the Common tab, configure any options, and then type your comments in the Description box. (For more information, see Configure Common Options.)

  7. Click OK. The new preference item appears in the details pane.

share|improve this answer
    
Hi almost done but!-- in the file extension box I have typed .iso but the associated class does bot have "vlc media file .iso" (plenty of other vlc file types) although vlc player happily plays ISO files –  Terry Rogers Dec 17 '12 at 20:35
    
From the article: "You do not need to insert the period before the file name extension." –  Karan Dec 17 '12 at 22:37
    
Sorry for long delay - Have tried with and without the period but the file type does not appear in the associated class (have tried a few random) but none work :( –  Terry Rogers Dec 22 '12 at 22:01
    
Hi all any more help with this would be great :) –  Terry Rogers Dec 29 '12 at 23:31
    
Did you press F3 to display the list as mentioned? Other than that unfortunately I'm all out of ideas as to why it's not working. –  Karan Dec 29 '12 at 23:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.