Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to help a friend with a desktop upgrade. It is an old machine with an Intel DG31 main board. The board has 1 IDE port to which a DVD-ROM drive is connected, and 2 SATA ports. 1 SATA port had a hard drive with XP on it. I have made that the secondary drive now and wiped the OS as requested, so it is just for data. The new SSD has been installed but I read that for best results one must enable AHCI in the BIOS? So I checked and in the BIOS there is a SATA Mode setting with 2 options - Native and Legacy. I think Native means AHCI? After setting to Native, I installed Windows 7 Home Premium and all the latest drivers from Intel's website and all Windows Updates. Now when I check Device Manager I see this:

1

Also Microsoft says HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci\Start and HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV\Start should have value 0 for AHCI but I see that the value is 3 for both. So does this mean that Native mode is not AHCI? Or Windows 7 ignored BIOS setting and installed in IDE mode, maybe because both cables are present? Please help me enable AHCI on this system. Thanks!

share|improve this question
    
Windows tends to install in AHCI mode if it's set in the BIOS, and if it cannot find the drivers it will not even show the HDD during setup (you'll need to load the drivers from a USB stick). So the fact that it still installed in IDE mode (going by the registry values) seems to suggest that either: i) AHCI is disabled due to the presence of an IDE device, ii) AHCI is enabled (but not displayed) for only the SATA HDDs, or iii) AHCI is not supported at all by your MB. I do not know how to confirm however since I don't have access to a PC with both disk controllers (which complicates matters). –  Karan Dec 18 '12 at 19:25
add comment

1 Answer

It is generally not a good idea to change from IDE to AHCI after you have installed your operating system. Drivers problem and such. However, you can try changing those two AHCI registry values, HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci\Start
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV\Start
from 3 to 0.
It worked for me and windows installed AHCI drivers for my drive, however I must warn that YMMV so please do back up or take precaution before trying it out.
Or you could just reinstall windows after setting your SATA to AHCI mode.

share|improve this answer
    
I've done this before and it was pretty safe. Just required a couple of reboots to get all the drivers installed automatically by Windows. However, I've never tried this on a PC that has IDE as well as SATA, so no idea if it will cause a BSOD, or perhaps break the DVD drive... –  Karan Dec 18 '12 at 19:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.