Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

first of all I must admit, that I'm not good in all this network stuff.

I am using Windows 8 OS.

On my laptop (Lenovo G570) I have installed Windows Phone 8 SDK and shortly after this I started having weird issues with internet connection.

When I start my laptop, internet usually works fine, but after a few minutes it starts slowing down so much, that I'm not able to open a single page. Rebooting doesn't work, after several disabling and enabling network adapter, it usually works again for a few minutes and then again it stops.

I'm sure it has something to do with Windows Phone 8 SDK, because problems started with this.

With SDK there was also installed "vEthernet (Internal Ethernet Port Windows Phone Emulator Internal Switch)" network adapter.

It is worth to note that problems occur mostly in my school network, not at home.

Both at home and school I am using Wi-Fi connection.

I hope the information given are enough to help me.

Thanks in advance for any answers!

share|improve this question
2  
I assume vethernet is a virtual ethernet. See if it exists as a connection - Control Panel->Network and sharing-> left side open change adapter settings. Do you see the vEthernet connection in here? If so, right click on it and disable, and then enable your 'real' connection and see how this goes. –  Dave Rook Dec 18 '12 at 10:05
    
@DaveRook Thanks Dave for the answer, I did as you told me, I disabled vEthernet, rebooted after this. At first I thought it's ok, but after few minutes connection again was 'lost'. –  Piotr Chojnacki Dec 18 '12 at 10:43
    
@DaveRook No, it stays disabled. –  Piotr Chojnacki Dec 18 '12 at 10:44
    
Have a look at this Microsoft article : Troubleshooting the Windows Phone 8 Emulator. –  harrymc Jan 8 '13 at 12:29

1 Answer 1

up vote 2 down vote accepted
+50

Disable the virtual connection:
Control Panel -> Network and sharing -> left side open change adapter settings.

Right click on the virtual connection and select disable, and then enable your 'real' connection and see how this goes.

As per your comments, you are able to do this but after reboot, after a few minutes, the problem persist and connection is lost (although the V-ethernet remains disabled).

Since there is no difference between your "ping" of both your local router and 8.8.8.8 (eg ping 8.8.8.8) it confirms it is your machine.

Update

I would now open start, type in msconfig and in the start up menu, look for anything which is called vEthernet and disable it.

I would also open start, type in task s (to load task scheduler) and ensure there is nothing in here about the vEtherent.

Lastly, I would open start, type in services.msc and check here - it could be in there as a delayed start (this may be hard to find!)!

If there is no luck with the above, try a system restore.

Update 2

On the host computer, open Internet Options from the Control Panel. The Internet Properties dialog box opens.

In the Internet Properties dialog box, click the Connections tab.

On the Connections page, click the LAN settings button. The Local Area Network (LAN) Settings dialog box opens.

In the Local Area Network (LAN) Settings dialog box, deselect all the check boxes. Click OK twice to close both dialog boxes.

Restart the emulator and retry the connection.

Source

share|improve this answer
    
Ok, so it looks like there is 25% of loss in both cases. –  Piotr Chojnacki Dec 18 '12 at 11:22
    
@Mosquito - I have made an update –  Dave Rook Dec 18 '12 at 11:48
    
I'm trying to do a system restore, because I haven't found anything that would be associated with this vEthernet! I'll post results. –  Piotr Chojnacki Dec 18 '12 at 11:55
    
System restore did the trick. :-) Though it was quite radical approach, I'm glad it works now. Thank you, Dave for help! –  Piotr Chojnacki Dec 18 '12 at 12:55
    
@Mosquito No worries - I'll also recommend you create another restore point as well, before re-attempting the SDK. –  Dave Rook Dec 18 '12 at 13:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.