Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I prefer all my windows to be centered when created so I went to Window Manager Tweaks » Placement and set Maximum size of windows to trigger smart placement to Max (large) and also checked At the center of the screen.

This works fine until I do a reboot when the settings appear to not have changed but new windows aren't placed at the center anymore (but in empty spaces on the desktop instead [default behavior I think])

Is there a way to fix this?

P.S. Issue occurs in both Xfce 4.8 and 4.10.

share|improve this question
add comment

1 Answer 1

I had this problem too, this is how I got around it:

  1. Find out which xfwm4 theme you're using with the "Window Manager" section on the settings manager.
  2. Suppose it's "Zukitwo", edit the file /usr/share/applications/Zukitwo/xfwm4/themerc with your preferred text editor (you'll need root privileges).
  3. Comment out or delete the line placement_ratio=20
  4. Log out and log back in. It should be fixed now.

This placement_ratio variable corresponds to the slider on the Window Manager Tweaks settings. Its default value is 20, and the max is 100.

For some reason, some themes include this option in the themerc file and it overrides the value set by the user upon login.

Maybe this is not your case, but it's worth a try!

Lourenço

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.