Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a computer at work that I can only connect to remotely when using the computer's IP address and not when using the computer's name.

I can see my computer name is set up correctly as "JoshPC" (for example), and there don't appear to be any conflicts with other PCs names.

What could be going wrong? I've flushed the DNS cache on the PCs attempting to remote in but no luck.


  • The PCs are on the same network as each other
  • I've tried ipconfig /registerdns and received no errors (although not waited 15 mins yet)
  • ping -a [IP] gives the right name
  • I've tried using the fully qualified computer name
share|improve this question
up vote 9 down vote accepted

I hope you are connecting from a machine in the same network and both are Windows. From the machine where you are remoting to JoshPC, What does ping -a <IPofJoshPC> give? Does it give a different computer name? If so then your DNS server is not updated with resource records of JoshPC. From JoshPC, try ipconfig /registerdns. It will take 15 mins or so to register that computers resource records with DNS.

Edit1: Saw you update. Interesting! After some waiting, if it still does not work, i suggest trying to access machine with FQDN if you have not tried it yet. I did not encounter this error inside office, but when i used VPN from home, i usually get this errors. Just giving computer name will not connect, but giving the Full-Qualified name will connect.

Edit2: If the above fails, try using nslookup for JoshPC and compare the IPs you get. If these are different, then your DNS is definitely not updated. Try contacting administrator or flushing and registering with DNS.

share|improve this answer
+1 for useful tips and "ping -a [ip]" I didn't know about the "-a" switch to get the name! 1) it's on the same network - 2) "ping -a" gives the right name! - 3) "/registerdns" didn't help – Josh Comley Oct 7 '09 at 8:21
Did you wait for sometime :)? after registerdns? If it encountered errors, please check event viewer for any indications.Do you have some errors there? – vpram86 Oct 7 '09 at 8:22
@Aviator I've updated my question! – Josh Comley Oct 7 '09 at 8:26
Does ping -a give a name like JoshPC.domain.local and can you ping that fully qualified name? Also is it in a similar format to other machines that you can ping? Can anyone other computers access JoshPC by name? – sgmoore Oct 7 '09 at 8:31
@Aviator - good point about FQDN but that was actually one of the first things I tried. It didn't work, but the IP does. I'm so baffled as to why "ping -a" gives the right name!! It seems like the DNS is working one way but not the other. – Josh Comley Oct 7 '09 at 8:31

It seems that the DNS Server (the one holding the IP -> Name resolution) has cached wrong IP -> name pair. Ask your System Administrator to remove the entry & then try remoting.

share|improve this answer

I've had this issue occasionally and it's been our experience so far that it might be linked to high CPU usage. If the CPU is being hammered, connecting through RDP becomes unreliable. Either we can't connect at all or we experience the same phenomenon of being able to connect with the IP, but not the host name. If we wait for the CPU to calm down, then it works more consistently.

I realize this is anectdotal, but I hope it helps.

share|improve this answer

This is related to RDP Security at the other end (Set to TLS or high) and using certificate from some internal CA

share|improve this answer

I ran into this same issue when I came across this page. On my machines, I noticed that pinging the host by its computer routes the ping outside of my home network to my ISP, but when I ping the client by its computer name (from the host) it finds it normally on the network.

Here is the output of pinging the host from the client by its computer name:

Pinging [67.215.65.XXX] with 32 bytes of data:
Reply from 67.215.65.XXX: bytes=32 time=14ms TTL=51
Reply from 67.215.65.XXX: bytes=32 time=34ms TTL=51
Reply from 67.215.65.XXX: bytes=32 time=14ms TTL=51
Reply from 67.215.65.XXX: bytes=32 time=12ms TTL=51

Ping statistics for 67.215.65.XXX:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 12ms, Maximum = 34ms, Average = 18ms

While pinging the client from the host by its computer name shows:

Pinging CLIENT [] with 32 bytes of data:
Reply from bytes=32 time=5ms TTL=128
Reply from bytes=32 time=1ms TTL=128
Reply from bytes=32 time=1ms TTL=128
Reply from bytes=32 time=1ms TTL=128

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 5ms, Average = 2ms

Maybe someone has any more insight on this?

My router is running DD-WRT v24SP2-MULTI (11/20/11) std. I have not forwarded RDP ports because I only use remote desktop internally.


It appears the issue had to do with the DhcpDomain registry key. For some reason it was set to on one computer and my business's domain on another even though both were my home computers. Setting them to blank fixed the issues I was having.

Edit DhcpDomain="" in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces\\

share|improve this answer

protected by studiohack May 20 '12 at 16:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.