Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to add a particular word to my custom dictionary using Word 2007. (The word happens to be "deserialized".) When I right-click on the word and click Add to Dictionary, the red underline does not go away. When I use the Spelling & Grammar tool from the Review tab on the ribbon, it will stop on that word; clicking the Add to Dictionary button has no effect.

Oddly, I am able to add other words to the custom dictionary without a problem. I recently added "deserializes", for instance. I have only encountered this problem with that one particular word.

Does anyone know what might be wrong and how I might fix it?

Clarifications

My document and all its content is set to English (United States). My custom dictionary is set to apply to All Languages, which is the default value.

"Serialize" is in the US English default dictionary, but "deserialize" and its various forms is not.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

In Word 2010 at least, File / Options / Proofing / Custom Dictionaries displays the path to the custom dictionary file being used. Generally it is %AppData%\Microsoft\UProof\Custom.dic (should be the same in Word 2007 as well), so try opening that file in Notepad (after closing Word) and check if the word has actually been added to it. If not, add it yourself on a new line, save and close, open Word, then check if it recognises the word.

share|improve this answer
    
Indeed, the word was missing from the custom dictionary file despite many, many attempts to add it. Thanks for your help! –  WCWedin Dec 19 '12 at 15:04
add comment

That word is in the main dictionary.

What LANGUAGE is Word set to and what language is the document (even the specific part of the document you are using) set to?

It may be that it is set to UK English and so is marking the spelling as incorrect (it is correct American English of course ;)

share|improve this answer
    
I've added some clarifications to the description. I doubt this is an issue of the language settings, especially since if I were using a UK English default dictionary, I should still be able to add US spellings to my custom dictionary. –  WCWedin Dec 18 '12 at 16:10
    
OK, fair enough. Just tried this on my own copy of Word 2013 (UK) and I don't get this problem with either form of the spelling. I'd now say that @Karan may be more on the right lines. –  Julian Knight Dec 18 '12 at 22:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.