Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I hope I've found the right place for this question. It's a long question, and has a little bit of a background I'd like to cover. The question, or issue, I'm having will become obvious. I think it is related to a problem I am having with IE9, so I will describe that first,

I support a number of users, and we just upgraded a PC we had from Vista to Windows 7 (32-bit) and gave this PC to a new user. This was a couple of weeks ago

My boss did the actual upgrade, but reported no problems connecting online.

Now when I brought the PC to the new users desk and hooked it up, I started having errors access high graphic content sites with IE9, though I did not have the same problem using Firefox. I asked the user to use Firefox until I found a solution, and but so far have not had the opportunity to research it.

Now, this user has to connect to a remote site via a gateway use the builtin Remote DeskTop Client. When she starts MCTSC.exe it starts just fine and prompts for credentials. After entering them in a connection is established and the remote desktop is diplayed on her screen.

However, after about half a minute, an error appears. It only says Mstcs.exe has terminated abnormally. I don't have a screen shot of it, but the module reporting the error is the C++ Runtime Library.

I also was able to extract this from the event log which appears to be related (Compter name was changed to protect the innocent):

Log Name:      Microsoft-Windows-TerminalServices-LocalSessionManager/Operational
Source:        Microsoft-Windows-TerminalServices-LocalSessionManager
Date:          12/18/2012 11:17:50 AM
Event ID:      17
Task Category: None
Level:         Error
User:          SYSTEM
Computer:      Accounting-PC.GCPMS.local
Remote Desktop Service start failed. The relevant status code was 0x800706b5.

Event Xml:
<Event xmlns="">
    <Provider Name="Microsoft-Windows-TerminalServices-LocalSessionManager" Guid="{5D896912-022D-40AA-A3A8-4FA5515C76D7}" />
    <TimeCreated SystemTime="2012-12-18T17:17:50.898200000Z" />
    <Correlation />
    <Execution ProcessID="532" ThreadID="812" />
    <Security UserID="S-1-5-18" />
    <EventXML xmlns:auto-ns3="" xmlns="Event_NS">

I cannot figure out what to do, but I am leaning toward copying Mstcs.exe and a the RDP files with a set from another similar installation.

I cannot find a repair for this, nor a download to reinstall it, much less find a way to remove it in order to reinstall it. I'm not sure what else to do. I tried manually starting the service, but it still did not stay connected.

Please note: When the error appears in RDP, if I ignore the message, I can still use the remote desktop as if there wasn't a problem. I haven't tried interacting with the local machine, but the RD stays up and active until I click on OK from the error message box. Then RDP shuts down.

I've spent at least an hour browsing the tech boards looking for a solution, but haven't found any that applies to me. Your help is needed and appreciated.



share|improve this question
We're going to need WAY more information than this; Right now it's more of a story than a question. Is that Event Log entry from the computer you're trying to RDP FROM or TO? Anything in the other computer's event logs? Does it work from another account? Can you access the same RDP connection from other machines on that same network? Are there any RDP policies being applied to the domain? Have you done disk checks and SFC yet? What exactly have you tried already? If it's not working right and you're having other weird problems (like your IE9 troubles), why not just re-install Windows? – Ƭᴇcʜιᴇ007 Dec 18 '12 at 18:56
A search of the error suggests the problem could be RemoteFX-related and since you're having graphics problems with IE9, it could be a graphics card driver problem. Please uninstall the graphics driver and install the latest version for Windows 7. – Dec 18 '12 at 20:14
Sorry about the run-on. – Marshall Dec 19 '12 at 14:36
Sorry about the run-on. I'm a developer, not a network tech, but I'm about the best the have here. I just wanted to point out that I'm having a issue with IE9 that may, but not necessarily, related, and that that problem also is on just this one machine. The log is from the same machine (i.e. the computer we are connecting from). I haven't checked the other computers logs, but I can. I have the same problem using my credentials on the users machines, so I'm sure it's not related to the connections as much as it is a problem with the client on that machine. – Marshall Dec 19 '12 at 15:06
My boss and I are able to make the same connection from our PC's using the that users credentials. All I knew to do at that point was to check the version numbers and look for something out to the ordinary and to post something here. It is a site accessed daily by many of the users in the office. I do not know if there are any Group Policies, but I am pretty sure that what ever default policies may exist would be the only ones present currently. I'll try the disk check when the user goes to lunch, not sure what a SFC is. – Marshall Dec 19 '12 at 15:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.