Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Before this, rss pages were displayed in the browser window with a nice formatting as a content.

On an rss page, I accidentally checked Always use Live Bookmarks to subscribe to podcasts. and then the Subscribe Now button. (Note that I have a non-default dark theme in Firefox, but this is still just native Firefox.)

rss before

Now every time I visit the rss page, the content is not displayed, and all I get is a dialog titled Subscribe with Live Bookmarks.

rss after

I searched on the net and I found that I should go to Tools menu (in F10 or Alt+T), select Options, then on the Applications tab I should filter to 'Web Feeds' and set it to Preview in Firefox.

options1

Now here is my problem. I still only get the dialog titled "Subscribe with Live Bookmarks". I've tried to disable all Add-ons from the Help menu and start Firefox in safe mode, but it didn't help. I've even tried to delete the live bookmark I added, but it didn't help neither.

My Firefox version is 17.0.1, I'm running on Windows XP pro SP3 32bit, my user is administrator, I have all rights in the Mozilla folder in Appdata and I have more GB free disk space.

What should I do to make Firefox display the rss pages again as content, instead of bookmarking?

share|improve this question
add comment

1 Answer

I found out that in the about:config page (URL/address) if I write "feeds" to the filter, I get several pages that are not on their default settings, but user set.

about settings

I reset them all by right clicking them and selecting Reset all of them.

reset

Now it works! Firefox is displaying rss pages as content again!


Fellow users or ux designers may find my detailed struggle useful.

The setting names make it evident that not all rss go by the name "Web feeds". I probably "should have realized" in the first place that they are called podcasts (as they are that), but, to me, these were always just rss pages.

I went instead to Tools menu > Options > Applications again, and wrote "feeds" to the search box. But got only "Web Feeds". (I've also tried "audio", no luck.) I searched then for any entry with an "rss icon". That's how I realized that "Podcast" and "Video Podcast" is where it must be set, if you use the UI.

the right place

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.