Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to disable/enable USB camera using devcon. It fails with the following output: c:\temp\devcon>devcon disable "USB\VID_199E*"

USB\VID_199E&PID_8207&MI_00\8&11CAF5B4&0&0000               : Disable failed
USB\VID_199E&PID_8207\16210163                              : Disable failed

I execute devcon in a console run with admin privilegs

What could be the reason?

Thank you!

share|improve this question

migrated from stackoverflow.com Dec 18 '12 at 21:27

This question came from our site for professional and enthusiast programmers.

    
Thank you for downvoting! An explanation would be nice. Anyway, if you could find a similar question on SO with a working answer, please tell me - i couldn't find it. I've tried to follow instructions from youtube.com/watch?v=rtaDu8QStQM - no success. –  Valentin Heinitz Dec 18 '12 at 18:54
    
"DISABLE FAILED NO DEVICES DISABLED" DEVCON.EXE | HOW TO DISABLE DEVICES FROM COMMAND PROMPT" Try this link: delphintipz.blogspot.com.es/2012/07/… –  user209573 Mar 22 '13 at 14:36

1 Answer 1

I have such issue when tried 32-bit devcon.exe (located in Program Files(x86)) on 64bit Windows 7. Solution is to use 64-bit version of devcon.exe

Also, you need to run devcon with admin privileges (ie, start cmd as Administrator, then run devcon).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.