Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I enabled some password expiration policies on my Linux box and am able to see a warning when login: Warning: your password will expire in X days. This works also on screensaver when entering my password to unlock the session. However, the message disappears rather quickly. I would like to delay it a bit - few seconds will be enough.

How I can do this? If not - how I can delay the session login after the user press "Login" button?

The goal is to make the message stay on the screen a bit longer, so the user can read it.

Thanks!

share|improve this question

1 Answer 1

For lightdm, you could try different greeters (lightdm-unity-greeter, lightdm-gtk-greeter); they would have settings in /etc/lightdm/, including at least font size setting and a theme name (you could work on that theme to make the message easier to read). I have not seen those have a delay setting.

It is possible to file bugs against lightdm here, if you don't think the above options resolve your query (even if the alternative display managers do the task, the lightdm folks would appreciate feedback).

xdm man page here has an "Authentication Widget" section - you can at least set a larger font face for the message, so the few seconds the user gets are enough to read the message.

The same xdm man page suggests that a session is started after a user logs in. For example, I have an ~/.xsession file which starts an Xfce session; adding a 'sleep 5;' at its top below the #!... line might add a five seconds delay while the 'password expired' message would show up - or it could already disappear before the session starts. I haven't checked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.