Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running VMWare Workstation on Windows 7 x86-64, and a Mac OSX 10.8 inside the VM. Whenever I try to connect my USB drive to the Mac OSX guest, it just doesn't gets recognized, i've already tried restarting, changing ports and all but nothing works ): Can I get help, please?

edit: USB works on Host, only not on Guest

share|improve this question
    
What is the USB formatted as? –  bungeshea Dec 25 '12 at 21:46
    
@bungeshea NTFS. It won't even show up in the "Removable Devices" list. –  wingleader Dec 25 '12 at 22:31
    
this is why some people simply jump into BootCamp. Make sure the pendrive is not already mounted (automatically, probably) in OSX. also, are you sure you have ntfs support? –  Lorenzo Von Matterhorn Dec 31 '12 at 21:04
    
@Znau the fact is, it won't even connect to the guest, so it isn't appearing even on disk utility. it's not showing up in the list of devices i can connect. –  wingleader Jan 2 '13 at 21:01
    
@wingleader part 2 of my comment: are you sure you have ntfs support? –  Lorenzo Von Matterhorn Jan 3 '13 at 16:41

1 Answer 1

Hope this solves your problem

in the execute prompt type:

diskmgmt.msc

then, select the usb drive and change its letter to one not in use in the system. close the utility, and check if the drive now displays correctly. if not, unplug and re-plug it in.

NOTE: this answer is obsolete since new data reached me through the question owner. will update this answer when (if or not) the problem is solved.

share|improve this answer
    
Uh, am i supposed to do that on the host? Why? There's no letter conflict happening here ._. –  wingleader Jan 4 '13 at 19:20
    
100% your problem matches drive letter issue symptoms. give it a try, no harm comes out of it. –  Lorenzo Von Matterhorn Jan 4 '13 at 19:33
    
Okay, i'l try it and report back in a few hours( or days >_< ) –  wingleader Jan 4 '13 at 19:53
    
if you dont want to be helped, dont post a question. your host is probably having drive letter assignment problems, caused to an already in use drive letter being attempted to be assigned to a new drive(your usb drive). if the drive isnt detected by the OS hosting the VM, the VM itself wont detect it. –  Lorenzo Von Matterhorn Jan 5 '13 at 11:28
    
Dude, the drive IS detected by the OS hosting! It's just VMware that is bugging around this... Also, i do want to be helped, but you don't always have your files when you want, where you want. –  wingleader Jan 5 '13 at 14:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.