Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to turn on SFTP server in Fedora 17. What are the steps?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

If you need the sftp service that comes with SSH, it should be enabled by default with SSH itself. You'll want to enable port 22 connections from the outside however.

iptables -I INPUT -p tcp -m state --state NEW --dport 22 -j ACCEPT

You can also do the following if you want to start/restart the service for the current boot session:

service sshd restart
share|improve this answer

I was able to figure out how to do it

I decided to use vsftpd which is very secure ftp daemon and it worked. I'm still a little unsure what is going on, hopefully someone can make this a canonical answer.

First make sure that you have vsftp installed, as root run this:

/sbin/service vsftpd status

If it isn't installed, install it:

yum install vsftpd

Edit the config file: /etc/vsftpd/vsftpd.conf

Set anonymous_enable=NO if you don't want other people logging in anonymously.

Start it if it is not started already:

/sbin/service vsftpd start

From the other machine use this command on commandline:

sftp yourusername@yourIPaddress

Then you are prompted for a username/password.

You may have to check over your SSH settings as defined in this site:

http://forums.fedoraforum.org/showthread.php?t=283775

If you are logging in to the FTP server through a router, you may have to add a port forward.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.