Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running Win 7 64-bit SP1 with 8 GB RAM. I first noticed this problem when using the GUI to copy some large (5+ GB) files from one disk to another. What happens is the physical memory in use rises quite quickly to 100% and the system comes to a crawl. If I just start to access the file in a media player (it is a movie) the memory usage climbs up slowly but eventually reaches 100%.

When copying the same files via XCOPY I do not have this problem.

Using RAMMAP I see most of the memory usage is under "Mapped File" and is allocated under the "Active" column. If I select "Empty System Working Set" the RAM usage drops back down but then starts to climb back up.

Any ideas on what I can check/test to eliminate this issue?

share|improve this question
    
Just to clarify, when you use xcopy, the system doesn't slow down? –  dangph Dec 19 '12 at 5:23
add comment

2 Answers

You have to request an updated version of the Microsoft Windows Dynamic Cache Service that runs on Win7/Server 2008 R2 from the Microsoft support to limit the file cache and prevent it from "eating" all your RAM.

share|improve this answer
add comment

If you don't want to update your "Microsoft Windows Dynamic Cache" Service as proposed by @magicandre1981 then you could always use the the Sysinternals tool Cacheset to try out individual settings. Be aware that this can have adverse side-effects on your system.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.