Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In windows 7 , we can define a hotkey for connect to internet via VPN connection immediately without any prompt, through these Steps:

  1. Create shortcut for VPN connection for example in Desktop.
  2. Define a hotkey for that shortcut
  3. In VPN properties >> options TAB >> dialing options >> uncheck this checkbox : "prompt for name and password..."

This checkbox not exist in windows 8

so we cant define in Windows 8 like that.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You need to cache the credentials while creating the VPN connection:

  1. Charms bar / Search / Type vpn / Click Settings / Click Set up a virtual private network (VPN) connection:

    1

  2. Click Remember my credentials to save your credentials on the first successful connection attempt:

    2

  3. Now you can click on Charms bar / Settings / Network icon / Click the name of the VPN connection / Click the Connect button:

    3
    4

  4. You can create a shortcut to the connection by going to the Charms bar / Search / Type vpn / Click Settings / Click View Network Connections, or by going to Control Panel / Network and Internet / Network Connections:

    5

  5. If you want a shortcut that automatically dials the VPN connection for you (which the one above won't), follow the steps mentioned here

share|improve this answer
    
is there any way to config that in all client with cmd or powershell or gpo, in active directory? –  saber tabatabaee yazdi Dec 21 '12 at 3:03
1  
As in, automate everything right from creating the VPN connection, saving the credentials, creating the auto-dialling shortcut etc.? I'm not really sure, will have to look into it. Try posting a new question and maybe someone who's done it already can provide a good answer. –  Karan Dec 21 '12 at 3:06
    
The "Remember my credentials" options has no effect for me, unfortunately. Windows 8 still brings up the "Network Authentication" dialog each time I connect to the VPN. –  hheimbuerger Apr 25 '13 at 8:35
1  
Seems like connecting once with the rasphone.exe as mentioned here (and linked in step 5) does the trick. Connecting successfully through the sidebar did not store the credentials for me. But after doing it once with rasphone.exe, it now has the credentials stored even when using the sidebar to connect. –  hheimbuerger Apr 25 '13 at 8:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.