Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a typical set up where by my SVN server is on a machine behind the firewall and I have a gateway machine which I can SSH into. When outside the network if I want to checkout the repository I would use a tunnel.

ssh user@gateway_machine.domain.co.uk 3690:svn_machine:3690 -fN

Then checkout:

svn co svn://localhost/branch/to/source

The problem is what to do if I already checked out a branch because then the SVN URL is:

svn://svn_machine.domain.co.uk/branch/to/source

Making the tunnel useless.

What can be done to make my system aware that connections to svn_machine need to go through gateway_machine when outside the network?

share|improve this question

Try setting up a proxy in the subversion servers file: ( ~/.subversion/servers in Linux)

[global]
http-proxy-exceptions = *.domain.co.uk
http-proxy-host = gateway_machine.domain.co.uk
http-proxy-port = 3690
http-proxy-username = user
http-proxy-password = pass
http-compression = no
share|improve this answer
    
Put this in ~/.subversion/servers file on the local machine correct? – iiSeymour Dec 19 '12 at 14:43
    
Yep, whichever machine holds your local SVN – Tim Radcliffe Dec 19 '12 at 14:48
    
This doesn't do trick, I might be missing something? This still gives svn: E670002: Unknown hostname 'svn_machine.domain.co.uk' – iiSeymour Dec 19 '12 at 15:03
    
If that doesn't work, there is an alternative route you could try here: stackoverflow.com/questions/82530/svn-over-http-proxy – Tim Radcliffe Dec 19 '12 at 15:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .