Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following problem with Lotus Notes email HTML signatures with image. The code for HTML signature is this:

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
 <head>
  <title>signature</title>
    <meta http-equiv="content-type" content="text/html;charset=UTF-8" />
 </head>
 <body>

<!--Signature itself-->
<div id="outer">
 <div id="header">
  [Name FamilyName] | [Title]
 </div>
 <div id="padding"></div>
 <div id="left">
  Line1<br>
  Line2<br>
  Line3<br>
 </div>
 <div id="right">
  <img src="file:///LocalPathToImage.png" style="padding-left:10px">
 </div>
</div>
</body>
</html>

When actually sending an email with HTML signature with image, image is shown on my computer (sender's email) and not shown on the receiver's computer. However, on the same receiver's computer, when other person sends an email with different HTML signature with different image, receiver can see the image!

I tried with image being stored on the network drive, and also on the Internet. Any ideas how to make sure image is seen on receiver's side?

Follow-up: Tried with embedding URI of the image, but now I don't see image in HTML signature even on my side, though in browser image is displayed.

I have also tried an image hosted in the Internet, it was not displayed on my side either.

I can see that images being part of HTML signature and being properly displayed are possible (received such emails), I just don't know which settings I should have.

share|improve this question

migrated from stackoverflow.com Dec 19 '12 at 15:54

This question came from our site for professional and enthusiast programmers.

2  
Your problem is that LocalPathToImage.png is local (not reachable on receiver's side). In mail preferences, Notes says that if you want to use HTML for signature, you have to copy/paste from another Notes rich text field. For instance, you can create your signature in an email body and copy/paste it in the signature box. –  Slauster Dec 19 '12 at 14:57
    
Please, confirm, I understood you correctly. I have now at hand HTML written signature. I am creating a new email and in the body signature appears with image being seen since it's on my side. I am copying now the signature, and pasting it into Preferences -> Mail -> Signature -> Rich Text (choosing this option). Now every time it will be this option. Is this what I do correct? Thank you. –  aza07 Dec 19 '12 at 16:22
    
In the general case, with a general email client, you cannot rely upon the client to display images. If you MUST show images to your client, attaching a file to the image is the most reliable way, but doing it "inline" is not really possible. Images are heavily guarded against in many mail clients and will simply not work, either because the hosting domain is blocked or for some other security reason. I would suggest that you simply not use images at all. –  allquixotic Dec 19 '12 at 16:27
    
There is only one receiver who is not seeing the image of signature, all other receivers can see the image. However, at the very same time the same receiver sees images of other HTML signatures! Since I don't have access to these other signatures to see the code, I am struggling on my side to make it work, as I assume, my settings are somehow wrong, which I am trying to resolve now. –  aza07 Dec 19 '12 at 17:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.